close

Privacy guaranteed - Your email is not shared with anyone.

xCode for Mac OS X Leopard & ImageMagick

Discussion in 'Tech Talk' started by Green_Manelishi, Oct 26, 2010.

  1. Green_Manelishi

    Green_Manelishi Knicker Knotter

    Joined:
    May 4, 2006
    Messages:
    4,716
    Likes Received:
    0
    Location:
    On the edge but not quite over ...
    I am trying to install ImageMagick on a Mac OS X Leopard platform. The installed xCode is 3.0. Installing IM fails due to requiring xCode 3.1. which I can download. My question: has anyone else any experience with this situation? Downloading 3.1. will take some time, even over FiOS, and if it's all for naught perhaps I'll just try and install IM on the Windows platform I own.
     
  2. jasonvp

    jasonvp Kantre Member Lifetime Member

    Joined:
    Nov 19, 2000
    Messages:
    3,055
    Likes Received:
    415
    Location:
    annoying the liberals in NorthernVA
    XCode is required because it's got the compilers built into it. And the ImageMagick package you're trying to install is obviously coming in source code format. I assume you're installing ImageMagick via Darwin Ports (ports) or something like that?

    You have access to XCode 3.1 via Apple's software update? I'd go ahead and just install it so you have the most recent version of the gcc compiler that Apple supports.

    jas
     

  3. Green_Manelishi

    Green_Manelishi Knicker Knotter

    Joined:
    May 4, 2006
    Messages:
    4,716
    Likes Received:
    0
    Location:
    On the edge but not quite over ...
    Yes, I installed everything and it seems to be working fine. Thanks for the response.