close

Privacy guaranteed - Your email is not shared with anyone.

USB ports having identity crisis!!!

Discussion in 'Tech Talk' started by Angel Of Death, Jun 19, 2006.

  1. Angel Of Death

    Angel Of Death Wrenches/BMWs

    Messages:
    219
    Likes Received:
    0
    Joined:
    May 28, 2004
    Location:
    Stateside finally!
    When I plug USB 2.0 peripherals into my USB 2.0 ports, a bubble/window pops up and tells me that my stuff will run faster if I plug it into a USB 2.0 port.

    :freak: ? eh? They're already USB 2.0 ports!

    I popped in my ASUS mobo CD and tried to install the drivers, but a text files came up and said that the drivers were installed with Service Pack1.

    I'm running Ws/XP/MCE/2005 also, sorry.

    I tried to update my USB drivers though Device Manager. No dice.

    Any ideas guys?

    Erik
     
  2. Brass Nazi

    Brass Nazi NO BRASS FOR U!

    Messages:
    1,956
    Likes Received:
    0
    Joined:
    Jul 4, 2005
    Are you positive that your hardware is 2.0 compliant? If so I would remove the drivers and re-install them. Somrtimes that will work even though it says that they are already loaded. I know some newer PCs have usb2.0 ports on the pc but, the ports that are on the monitor for convenience are 1.1 only.
     

  3. HVAC-TEK

    HVAC-TEK

    Messages:
    82
    Likes Received:
    0
    Joined:
    Jan 3, 2005
    Ok, here is the deal. Windows looks to be using its own drivers for your USB's. It may think your drivers are outdated. What you need to do is tool down to the computer manufacturer’s web site and download the latest drivers from them. This should fix your problem.

    If your system is custom made from a small computer shop, then go to the motherboard manufacturer’s web site for the chipset and USB drivers.

    KIM