Glock Forum - GlockTalk banner

1 - 20 of 34 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am not sure why I am having so many issues building this damn thing. I have built many rifles, but his thing has got me frustrated. It's so simple it stupid, or most likely it just me.
Bought an SS80 lower with Glock 43 trigger kit. I got the OEM 43 slide in the mail yesterday, slapped the thing on and the slide won't rack back. It barely budges. I'll pull it and it will move about a quarter of an inch to where I can see the barrel drop very slightly and ejection port opens a 32nd of an inch. That's as much as it will move. Any ideas would be greatly appreciated....
 

·
Director of civil unrest
Joined
·
9,890 Posts


On a serious note, I'd start asking some questions of your parts suppliers after careful examination/measuring of the parts.
Also, putting it down for a couple of days and then coming back to it has worked wonders for me in the past. Good luck on your build.
 

·
Registered
Joined
·
59 Posts
I read a below post about issues with the SS 80 kits. I don't know if they apply to your situation though.

Did your slide rack fore and aft before adding the trigger, on just the frame rails?

erad
 

·
Registered
Joined
·
4,774 Posts
Are the lower parts OEM?

Check the “tunnel area” first (it is where the barrel sits) and make sure it is smooth. Also, polish the locking block and rear rails.

Can you post a pic?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
with the spring and barrel out, it will slide back. the barrel engages and drops ever so slightly but then just stops not opening the ejector port. Its almost like the barrel feed ramp is getting caught on the slide block.
 

·
Registered
Joined
·
4,774 Posts
with the spring and barrel out, it will slide back. the barrel engages and drops ever so slightly but then just stops not opening the ejector port. Its almost like the barrel feed ramp is getting caught on the slide block.
Sounds like you need to sand that area more and wet sand it to smooth it out.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Are the lower parts OEM?

Check the “tunnel area” first (it is where the barrel sits) and make sure it is smooth. Also, polish the locking block and rear rails.

Can you post a pic?
Yes upper and trigger kit are OEM. I think it has something to do with the locking block not letting the barrel to drop.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Yep found the issue. The front slide block was defective. Looks like the company didnt grind the tab off of the back of the block. With the tab on, the barrel wouldn't fit over it preventing the barrel from dropping. This is also why my holes never lined up.
ss803.jpg
ss805.jpg
ss806.jpg
ss808.jpg
ss809.jpg
ss8010.jpg
 

·
Registered
Joined
·
20,896 Posts
Did they send you a replacement locking block?
 

·
Registered
Joined
·
1 Posts
having the same exact issue yesterday I’m gonna call them tomorrow and try to get replacement parts


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
689 Posts
I must have got lucky... my SS80 didn't come with the funky locking block. Everything went together and functioned fine even with the few
non-OEM parts I used. Sounds like QC may be a little lax.


Sent from my SM-G986U1 using Tapatalk

 

·
Registered
Joined
·
53 Posts
Yep found the issue. The front slide block was defective. Looks like the company didnt grind the tab off of the back of the block. With the tab on, the barrel wouldn't fit over it preventing the barrel from dropping. This is also why my holes never lined up.







that locking block looks like it was cast in a low-tech back-yard shop in India, seriously.
 

·
Registered
Joined
·
2 Posts
I just had the same problem. It is not nessesarily the locking block. I have a G43 and the SS80 worked fine with the regular G43 upper and barrel. The after market S3F barrel was the problem. I put that barrel in my G43 and it didnt work. The problem is the barrel hit the locking block cutting the crap out of it.
 

Attachments

·
Registered
Joined
·
5 Posts
I am having the same issue. The barrel and the upper slide was purchased from Brownells. After reading through the post here, I think I will order another barrel and try that first. When the slide is mated to the lower, it will not fully engage.
 

·
MacGyver
Joined
·
7,391 Posts
There is a youtube channel (marine gun builder) where the guy goes into extensive detail covering tricks/hacks/shortcuts on how to put these 80% Glocks together well, and avoiding problems, and improving the flawed design issues along the way.

I wish I had watched his vids before putting mine together-- but I was able to fix my issues on my own, so I guess the fun is the challenge.

Good luck.
 

·
Registered
Joined
·
1,515 Posts







that locking block looks like it was cast in a low-tech back-yard shop in India, seriously.
Aw come on now. I felt sorry for Mustafa since all the call centers are closed due to covid, and the mask manufacturers had all sewing slots filled, so I gave him a job as a plastics caster. He's still learning.
 

·
Registered
Joined
·
2 Posts
I am having the same issue. The barrel and the upper slide was purchased from Brownells. After reading through the post here, I think I will order another barrel and try that first. When the slide is mated to the lower, it will not fully engage.
I change to a “True” Barrel and it worked great. Good thing i had my regular G43 to see it was a barrel problem and not the build.
 
1 - 20 of 34 Posts
Top