close

Privacy guaranteed - Your email is not shared with anyone.

Samba help

Discussion in 'Tech Talk' started by Tanman, Jan 22, 2006.

  1. Tanman

    Tanman

    Joined:
    Jan 6, 2006
    Messages:
    30
    Likes Received:
    0
    I am running Fedora core on my linux machine that is on a network with this machine (windows machine.) I set up my Samba and can see the linux machine in the workgroup but I get a not accessable message when I try and access it, any ideas?
     
  2. njl

    njl

    Joined:
    Sep 28, 2000
    Messages:
    9,038
    Likes Received:
    1,715
    Location:
    :noitacoL
    Does the Linux machine see/log anything when you try to connect to a share? Are you sure you opened up the necessary ports/interface in iptables?
     

  3. Tanman

    Tanman

    Joined:
    Jan 6, 2006
    Messages:
    30
    Likes Received:
    0
    open ports, where?
     
  4. njl

    njl

    Joined:
    Sep 28, 2000
    Messages:
    9,038
    Likes Received:
    1,715
    Location:
    :noitacoL
    /etc/sysconfig/iptables
     
  5. Jack T.

    Jack T.

    Joined:
    Jan 23, 2002
    Messages:
    109
    Likes Received:
    0
    Location:
    Great State Of Oklahoma
    sudo su -
    service iptables stop
    setenforce 0


    after doing that, does it *still* not work?
    that will turn off the firewall and the goofy SELinux security stuff. . .if Samba works after turning that off, it will tell you where the problem is.

    eta: and it might be a user problem. what auth did you set up when you set up your samba? you *might* try connecting directly to the share using a differnt user from the "Map Network Drive" thing in windows. . .map to it rather than browse to it. . .am i making any sense at all?
     
  6. Tanman

    Tanman

    Joined:
    Jan 6, 2006
    Messages:
    30
    Likes Received:
    0
    I located the file but what do you want me to do with it?
     
  7. njl

    njl

    Joined:
    Sep 28, 2000
    Messages:
    9,038
    Likes Received:
    1,715
    Location:
    :noitacoL
    Read it. Try to comprehend it. Determine if it's causing the SMB traffic to be blocked. As Jack T. suggested, just turning off the kernel firewall (service iptables stop) is an easy way to see if the iptables config is a/the problem. With iptables "stopped", you have no active packet filtering. If the shares still don't work after stopping iptables, then either the problem is elsewhere or not solely caused by iptables.
     
  8. Tanman

    Tanman

    Joined:
    Jan 6, 2006
    Messages:
    30
    Likes Received:
    0
    Sorry I have only been using Linux for like 2 days. How do I turn off the iptables?
     
  9. njl

    njl

    Joined:
    Sep 28, 2000
    Messages:
    9,038
    Likes Received:
    1,715
    Location:
    :noitacoL
    You've already been told twice. If you want to learn a new system (Linux), you're going to have to read a little.

    # service iptables stop

    After running that as root, you hvae no active iptables kernel firewall rules. To turn it back on after testing samba with it off,

    # service iptables start
     
  10. Tanman

    Tanman

    Joined:
    Jan 6, 2006
    Messages:
    30
    Likes Received:
    0
    I have been given a command line and a file location twice, I have not however been told what to do with this command line. Should I add it to the file? If so where? Do I delete this file?
     
  11. njl

    njl

    Joined:
    Sep 28, 2000
    Messages:
    9,038
    Likes Received:
    1,715
    Location:
    :noitacoL
    Open up a terminal. From the "main menu" icon in X, Terminal should be under System Tools. In it, you should get a prompt ending in $, which is customary for user shell prompts. Use the su command to "set user" to root, and your prompt will end in #, signifying a root shell. Then you can enter the service iptables stop command.

    i.e.

    [njl@foo njl]$ su -
    Password: <enter your root password>
    [root@foo root]# service iptables stop
     
  12. Tanman

    Tanman

    Joined:
    Jan 6, 2006
    Messages:
    30
    Likes Received:
    0
    Thank you ;c