close

Privacy guaranteed - Your email is not shared with anyone.

Ruger MK III feed issue and ?'s

Discussion in 'Rimfire Forum' started by BigJoe13, May 8, 2010.

  1. BigJoe13

    BigJoe13

    Messages:
    211
    Likes Received:
    0
    Joined:
    Feb 7, 2010
    Location:
    NE Arizona
    Dida search for this and found nothing, so here is the problem.

    Have a Ruger MK III 4" barrel. I have 4 mags total that seem to work ok. It has about 4-5 hundred rounds through the pistol and I have had it for 1.5 years or so. Every time I use a bulk box of HP .22LR it jams on the feed ramp, cuts the nose of the bullet and fails to feed. This is in the neborhood of 1 in 5 or 1 in 8shots between jams. If I switch to a brick of Round Nose .22 LR I have had for 15 years or so it works 100 percent. I have let 2-3 friends shoot it and tell me they think the sights are off, then proceed to prove them wrong with 5-6 shots in a one inch group.

    I have field stripped it twice for cleaning, all parts are stock.

    Should I just call Ruger reguarding the issue?
    Any ideas reguarding a fix?

    Thank you in advance for any help.
     
  2. Lotiki

    Lotiki All that is man

    Messages:
    787
    Likes Received:
    4
    Joined:
    Feb 13, 2007
    Location:
    Aurora, Co
    Adjust the feed lips of your mags to bring the nose of the bullet up a tiny bit by spreading out the front part in very tine increments.
     

  3. BigJoe13

    BigJoe13

    Messages:
    211
    Likes Received:
    0
    Joined:
    Feb 7, 2010
    Location:
    NE Arizona
    Lotiki,
    Will do!