close

Privacy guaranteed - Your email is not shared with anyone.

Posts w/pics display posters local file path

Discussion in 'Announcements & Support' started by WIG19, Mar 1, 2005.

  1. WIG19

    WIG19 Light left on

    Messages:
    3,785
    Likes Received:
    0
    Joined:
    Oct 27, 2003
    Location:
    Renegade State
    It would appear (at least since 2/28) that something has changed in the forum software or the way it treats pics. Posting a pic (JPG, BMP, whatever) now displays the posters local file path of the pic on THEIR machine. Distinctly NOT good! Only diff in the path is that backward slashes are changed to double-forward slashes.

    What's up, and what can be done to mitigate this?
    Thanks,
    ;?
     
  2. NRA_guy

    NRA_guy Unreconstructed

    Messages:
    1,706
    Likes Received:
    1
    Joined:
    Jun 20, 2004
    Location:
    Mississippi, CSA
    Something I had wondered about, too.

    Also, I had wondered (after posting a picture linked to my personal web site) if I deleted the jpg file from my web site would GT folks still be able to see the picture.

    The answer is "no".

    The picture apparently is not actually loaded onto a GT server---it only points to browser via the link each time a user opens the picture.

    I guess the GT server would be quickly overloaded if they tried to swallow all the photos.
     

  3. WIG19

    WIG19 Light left on

    Messages:
    3,785
    Likes Received:
    0
    Joined:
    Oct 27, 2003
    Location:
    Renegade State
    You brought up a great point; wish more people would resize their JPG's down before posting them. Or if you have a traditional camera and get the CD made at Walmart, use the images in the Preview directory instead. They're just as good for posting, but are just thumbnails and about 20% the size of those other bandwidth hoggers.

    Anyway, also PM'd Sidearmor and will see what she says about this filepath anomaly.
    ^8
     
  4. Patricia

    Patricia Wild at heart CLM Millennium Member

    Messages:
    3,399
    Likes Received:
    0
    Joined:
    Apr 5, 1999
    Location:
    Flagstaff, AZ
    Guys, I have absolutely no idea what happened. I will talk to Eric about it today and ask him.
     
  5. Patricia

    Patricia Wild at heart CLM Millennium Member

    Messages:
    3,399
    Likes Received:
    0
    Joined:
    Apr 5, 1999
    Location:
    Flagstaff, AZ
    I did a brief test. Apparently, shorter file names will show up, but larger ones, especially those with characters other than letters or numbers don't. I'm sure Eric will have an explanation later this morning.

    Example:

    [​IMG]







    [​IMG]

    You can click on properties to see the file name of the pic above. It is shorter and doesn't contain characters that are not letters or numbers.

    I posted this mainly so Eric could see that I wasn't crazy. ;f
     
  6. Eddie C.

    Eddie C. Administrator Moderator CLM

    Messages:
    5,094
    Likes Received:
    33
    Joined:
    Feb 21, 2002
    Location:
    State of Confusion
    Nice motorcycle Patricia. Are you selling that?!??;f
     
  7. Patricia

    Patricia Wild at heart CLM Millennium Member

    Messages:
    3,399
    Likes Received:
    0
    Joined:
    Apr 5, 1999
    Location:
    Flagstaff, AZ
    Why yes Eddie, now that you mention it, I sure am! Just dropped the price too. :)
     
  8. WIG19

    WIG19 Light left on

    Messages:
    3,785
    Likes Received:
    0
    Joined:
    Oct 27, 2003
    Location:
    Renegade State
    I see that Car Talk aren't the only folks that have a "Shameless Commerce" Division. ;) Sweet ride.
    ;f
     
  9. WIG19

    WIG19 Light left on

    Messages:
    3,785
    Likes Received:
    0
    Joined:
    Oct 27, 2003
    Location:
    Renegade State
  10. Eric

    Eric Big Giant Head Staff Member Admin Silver Member

    Messages:
    62,594
    Likes Received:
    15,934
    Joined:
    Jan 1, 1970
    I have noticed the difference in how the file name of attachments is handled recently, but I am not sure why this is happening. GT's message board software has not been upgraded for several weeks. The only explanation I can think of is that a recent server OS upgrade on the GT servers might be causing this.

    At any rate, in the next week or so, the updated version of the site will begin going online and the first change will be the upgrade to version 3.X of the vBulletin software that powers this site. The new version of the software i substantially different than the old one and I believe that whatever is going on will be dealt with by the upgrade. I will post more when I know more. Eric
     
  11. WIG19

    WIG19 Light left on

    Messages:
    3,785
    Likes Received:
    0
    Joined:
    Oct 27, 2003
    Location:
    Renegade State
    Thanks Eric; that just slapped me in the face from an Information Assurance perspective. If I'm a bad guy and I know your IP and also have a specific filepath that I can try against, well....
    I'm not for making things easier for them.

    Hope the vB upgrade goes well.
    Thanks again,
     
  12. Eric

    Eric Big Giant Head Staff Member Admin Silver Member

    Messages:
    62,594
    Likes Received:
    15,934
    Joined:
    Jan 1, 1970
    This problem could easily beworked around for now by copying the image you want to attach to your drive root before uploading it. I hope the upgrade will fix things though.

    I just remembered that last week I removed the Apache webserver on the GT frontend boxes and installed Apache-SSL instead. This change was made preparatory to the addition of the upcoming paid membership tier. This change should have been transparent to any programs running on the servers, but now I wonder. It is possible that the Apache-SSL webserver handles things like uploads & upload filepaths differently than the standard Apache webserver. I am looking into this now. Eric