Glock Forum - GlockTalk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter · #1 ·
No problems/complaints with my Glock 27 Gen3 bought new Aug 2010 ... until last winter, so replaced (some upgraded) ALL springs, full deep clean with micro use of top lubes, et al. only to return to same problems. All new mags replaced old last winter as first solution! Can't be limp wristing as I have other snappy similar pistols.

Failure to feed all ammo (never used 180 grains or more)
Slide doesn't fully return sometimes
Some primers have to be struck twice, some were Am. Eagle, most are Fiocchi 165gr FMJTC

Found some nicks inside slide (photo) and sent it to Glock, their only suggestion after listening to my woes on the phone.
 

·
Registered
Joined
·
13,821 Posts
It's normal and will reach a point and then stop.
 

·
NRA Life Member
Joined
·
5,398 Posts
The slide lock peens the slide in the area in the Red Circles - Mark the slide on the outside with a marker and you will notice how it lines up exactly with the slide lock.

Check the extractor - is it chipped? could be causing an issue... make sure the extractor channel that engages the case rim is clear and clean for smooth operation during feeding.

Clean the striker channel liner with a clean dry q-tip and be certain there is no lubrication in the channel liner. This will help with the light strikes. Be sure the spring is also free of any lubricant.

Next, go ahead and try the 180Gr loads - I use 180Gr ammo exclusively with no problems.

That is what I would do in this case... Hope it helps you out!
 

·
NRA Life Member
Joined
·
5,398 Posts
Hey - which springs were "upgraded" and what does "upgraded" mean exactly?

At this point it would make sense to return to OEM springs. You are troubleshooting, so start with normal and then upgrade one spring at a time...

Hope that helps you out...
 
1 - 5 of 5 Posts
Top