Glock Forum - GlockTalk banner

1 - 2 of 2 Posts

·
Registered
Joined
·
912 Posts
Discussion Starter · #1 ·
Greetings good experts,

I purchased a new Glock 26 9mm at a gun show about 3 weeks ago. The first couple of times at the range, it was completely fine. But now, usually between the 6 and 7th round shot, I get a Failure to Eject. The handy brush extension rod that came with the G26 lets me pop it right out (after removing the magazine for safety, of course).

I do use several brands of ammo, 115 gr, and even thought it might be one of the 2 extended OEM clock mags (12 round) that I purchased.

I can get a FTE on at least every other magazine of 10 rounds that I cycle through.

The next time at the range, I plan to choose one brand of ammo, and try each of my four mags until I can possibly narrow down a mag only issue. Of course, I ran through this forum quickly and noticed from JR that new 9mm with FTE that "The issue is caused by the current 115 grain ammunition and resolved by switching our the recoil spring to a weaker unit."

Before I go out and try to change out the recoil spring, I was wondering if anyone else had this issue, or knew of something else to check.

Thanks for reading. I appreciate any advice/help that can be offered.

nc19
 

·
CEO Lone Wolf Distributors
Joined
·
3,081 Posts
Shoot 124 or 147 and the issue will be resolved. If you insist on shooting the weak 115 gr ammo you will need to reduce the recoil spring weight. Check Wolff gun springs for their line of G26 systems.
FYI: The problem is not with your mags
 
1 - 2 of 2 Posts
Top