close

Privacy guaranteed - Your email is not shared with anyone.

Mossberg SPX question

Discussion in 'Tactical Shotguns' started by JTB, Aug 29, 2010.

  1. JTB

    JTB always learning

    Joined:
    Aug 8, 2003
    Messages:
    285
    Likes Received:
    0
    Location:
    Lebanon PA
    OK I own one and last time I used it it hold and feed all seven from the magazine. When to use it today and if I put more then 3 shells in the magazine, nothing feeds. any ideas folks?
    Thanks
     
  2. Glocker08

    Glocker08

    Joined:
    Sep 22, 2008
    Messages:
    1,862
    Likes Received:
    0
    I don't own a Mossy SPX, but my first guess would be something is going on with the mag spring. Maybe its getting hung up on something or maybe you need to replace it with a stronger spring. This is just a guess of course.

    Also, were you using the same type of ammo each time ? If it was different, maybe thats got something to do with it.

    At any rate, let us know when you figure out what it is.
     
    Last edited: Aug 30, 2010

  3. JTB

    JTB always learning

    Joined:
    Aug 8, 2003
    Messages:
    285
    Likes Received:
    0
    Location:
    Lebanon PA
    Thanks, It was the same ammo
     
  4. mixflip

    mixflip

    Joined:
    Mar 4, 2009
    Messages:
    6,825
    Likes Received:
    5
    Most folks ignore or forget to properly clean their SPX before breaking it in but I dont think thats the problem. It sounds like the spring or follower is getting hung up somewhere? Possibly the interface inside where the mag extension meets the magazine?

    If its brand new. Clean it. lube it properly. Try and use a few boxes of 00 buck and that should break it in fairly well? I did it this way and have been popping off cheap lowbrass WalMart birdshot ever since with zero malfunctions ever since day one.
     
  5. F_G

    F_G

    Joined:
    Jan 11, 2010
    Messages:
    1,105
    Likes Received:
    107
    Location:
    Crown King, AZ
    I had the same problem occassionally with mine. It was the follower hanging up on the transition from the mag tube to the extension tube. I took a fine file and beveled the edges of the follower (the factory follower has very sharp edges) and with a round file chamfered the tube and extension. I have since had no more issues.
     
  6. skynyrd1911

    skynyrd1911

    Joined:
    Aug 20, 2007
    Messages:
    207
    Likes Received:
    0
    Location:
    Crowley's Ridge
    I've never had a problem with mine. Cleaned & lubricated first thing out of the box. Ran a couple of boxes of slugs and buckshot through it and then about 50 rounds of cheap birdshot. No issues whatsoever. Last time out 1 box of slugs and 25 rounds of birdshot, no problem. That being said, I've only run about 100 rounds through it total. Excellent shotgun for the money.
     
  7. JTB

    JTB always learning

    Joined:
    Aug 8, 2003
    Messages:
    285
    Likes Received:
    0
    Location:
    Lebanon PA
    Thanks, I have had it a couple of years so maybe it it the follower. I was think of getting a Choato spring and follower
     
  8. DFin

    DFin

    Joined:
    Mar 22, 2008
    Messages:
    2,065
    Likes Received:
    0
    Don't they come with Choate followers? The mag extensions are made by Choate.
     
  9. JTB

    JTB always learning

    Joined:
    Aug 8, 2003
    Messages:
    285
    Likes Received:
    0
    Location:
    Lebanon PA
    The follower is just a cheap piece of metal, best I can tell, the Choate are orange.