close

Privacy guaranteed - Your email is not shared with anyone.

Missing Hard Drive

Discussion in 'Tech Talk' started by Kimelac, Jan 12, 2007.

  1. Kimelac

    Kimelac Bada Bing! CLM

    Messages:
    433
    Likes Received:
    1
    Joined:
    Dec 16, 2003
    Location:
    fughedaboutit
    I have searched the internet for the solution to this and couldn't find anyone who had exactly my situation, so I am posting this here hoping that someone will know how to fix this.

    Background:

    I have an external HD (USB) that I used in the past for Linux (not an issue here) - and I re-formatted it to NTFS to use with Windows. It is a 160 Gig in size.

    I hooked the USB cable into the computer (I've got a windows, linux and mac here at home, don't ask...it's a long story) thinking that I could write to it using windows and read using the mac at least, if not Linux, although I know it takes some tweaking to get Linux to read it. I also understand Mac and the Linux box (OSX and FC6) aren't going to be able to write to the drive, and that's fine. I just want to store my music and pictures on it, and I will put them on using the windows box (WinXP Home SP2). I loaded iTunes on the windows box, it's already on the mac, I'll deal with a substitue for FC6 later, and loaded all the CDs (~1600 songs) I could find here at the house. I've also downloaded some stuff from iTunes, and it's all on there as well. It was dinner time, so I hit hibernate on the windows box, unplugged the HD from the AC outlet as its power cord was strung across the floor, and went to eat.

    When I came back I turned on the computer and once it was up and running I plugged back in the HD, and iTunes couldn't find anything that I had loaded. AC power? Check. USB? Check. Checked My Computer, it had another HD listed. I changed the location of my files on the iTunes setup or preferences or whatever it's called, and iTunes sees all my stuff on the 'new' HD. The HD that it was supposed to be on was F:\ and now it's all on G:\ . Looking at the icons for F:\ there is a big question mark on it, and there are no options when I right click for a pull-down menu. No way to browse the HD, no way to delete it, no way to do anything with it, cause Windows can't find it. Crap.

    <img src="http://www.glocktalk.com/attachment.php?s=&postid=7499667 "></img>

    I unplugged the HD, G:\ disappeared, hibernated the computer, and plugged it back in. When restarted it, I still have the unknown F:\ drive, and a good G:\ drive. I dont really care at this point what letter it uses, except that if it keeps changing, it'll be a pain in the butt to keep changing my iTunes settings, but I do want to get rid of the unknown F:\ drive. I have checked all thru the control panel, can't really FDISK something that doesnt exist, so I am at a loss. I have also restarted the computer with and without the HD conencted. Each time, whichever way I go, it loads it as G:\ and has F:\ missing.

    Can anyone point me in the right direction? what do I do to get rid of this disk? and possibly reset the HD from G:\ to a newly available F:\ ?
     
  2. Bluzman

    Bluzman

    Messages:
    664
    Likes Received:
    215
    Joined:
    Aug 1, 2004
    Location:
    Arkansas
    Looks like another partiton is showing up on your PC. What internal drives do you have? Did the Usb Drive get formatted and partitioned properly? Partition Magic might help you see what's up.
     

  3. NetNinja

    NetNinja Always Faithful

    Messages:
    967
    Likes Received:
    0
    Joined:
    Oct 23, 2001
    Location:
    HotLanta, GA
    Try this.

    Anything that is permanently attached to the computer assign the drives thier respective drive letters.

    I see a C: D: E: and the CD rom as H:

    Set the CD rom as F:

    Reboot the computer with the external HD plugged in and see what happens. You may want to set up the external device as 1 big partition but that should not be an issue because I have done the same thing in the past.

    But let's see what happens.

    Once the computer has booted up lets try to reformat the external HD again.
    Since that was a Linux drive before and you had a Linux OS on it?
    I am wondering if the Linux MBR is still on the drive and that may be causing the problem with the unknown partition.

    Hope that helps.
     
  4. lens

    lens

    Messages:
    524
    Likes Received:
    11
    Joined:
    Nov 24, 2005
    Location:
    Northeast
    BEFORE you do anything to the HDD!!

    SHUT DOWN (do not "hibernate") your PC. Let it totally power down. Then plug the USB HDD in, power it up and then power up the PC. See if all is well again.

    It's well known that "hibernate" loses devices when revived. Thus, I almost never use it. Prefer to power down and then power up.

    Let us know how this works out.
     
  5. Dandapani

    Dandapani

    Messages:
    8,216
    Likes Received:
    13
    Joined:
    Mar 24, 2004
    Location:
    Gulf side Florida
    FYI, you don't need to power down your PC to plug in a USB drive. It's hot pluggable. And you need to "stop" it via the little icon in the lower right hand try before you unplug it, but that also is a hot unplug.
     
  6. Kimelac

    Kimelac Bada Bing! CLM

    Messages:
    433
    Likes Received:
    1
    Joined:
    Dec 16, 2003
    Location:
    fughedaboutit
    C:\ D:\ and E:\ are the internal hard drives.

    I a positive that the USB drive (G:\ ,formerly known as F:\) was partitioned and formatted correctly. I am positive this isn't an issue with the formatting.

    Partition Magic does things that windows does, just makes it look different and makes it easier for the avg. user. I don't think there is another partition showing up, because before I put the USB HD on at all, there was only C:\ D:\ and E:\. Once I plugged it in, there was F:\, then when I hibernated, removed it, turned the PC on, then plugged it back in - I got a G:\ and F:\ is missing. There is no other partition to show up.
     
  7. Kimelac

    Kimelac Bada Bing! CLM

    Messages:
    433
    Likes Received:
    1
    Joined:
    Dec 16, 2003
    Location:
    fughedaboutit
    Tried something very similar, which has shown me that this wont work. I tried to reset the G:\ drive to F:\, and F:\ isn't available to use. Everything available starts after the last letter used in the pic above. I then tried to reset the missing HD (F:\) to antoher letter, and that's when I found that there are no options to it when I right click to get a menu. Also tried using the HD management that comes with windows, that didnt help either.

    I have restarted with the HD plugged in, also hibernated with it out, then restarted with it in, hoping it would realize that it was the missing F:\ and both ways what I end up with is a missing F:\ and a new G:\.

    I'm not formatting this HD. Took me a week and a half to get all the shows and music on there from iTunes and my CDs... and I am positive it isn't a HD problem. The HD works fine. It just where windows thinks a F:\ should be, there isnt anything. All I want to do is help windows to realize that F:\ isnt missing, it doesnt exist, so it should stop showing it on the system, and let that letter be reused for something else.

    There was no Linux OS on the drive before, it was formatted to be used with Linux. Linux has a filesystem similar to NTFS that uses journaling, and I had it set up for this filesystem. I completely deleted the partition and all data on the drive, and then partitioned it and formatted using windows. I'm sure it's not a HD problem.

    Thanks for the advice I really appreciate the advice.
     
  8. Wulfenite

    Wulfenite The King

    Messages:
    1,862
    Likes Received:
    5
    Joined:
    Jun 1, 2000
    Location:
    Pretty Fly for a White Guy
    Might also be an itunes issue. One time with my recent hdd build, I moved all my itunes stuff over my network onto the new drive. It looked like it was all there...you could play the music etc etc. But when I shut down itunes and opened it up later it was all gone. In itunes when you're moving files around like that (instead of loading them properly off the disk), you have to "Consolidate the Library" which is a command under the Advanced tab.
     
  9. Kimelac

    Kimelac Bada Bing! CLM

    Messages:
    433
    Likes Received:
    1
    Joined:
    Dec 16, 2003
    Location:
    fughedaboutit
    Starting to see that. Hibernate is good sometimes here because all my background services dont always start up if I get impatient and dont want to wait for the to all begin and start using the computer when it first boots, instead of waiting for the like 3 minutes or so it takes to start up the BG services.

    I think I'll skip hibernating for a while and just shut down from now on. I might end up using all my available letters for 'missing' drives. :animlol:
     
  10. Kimelac

    Kimelac Bada Bing! CLM

    Messages:
    433
    Likes Received:
    1
    Joined:
    Dec 16, 2003
    Location:
    fughedaboutit
    I got that, I'm not worried about the USB portion of this either. I write USB drivers for work, and this USB drive is actually able to be removed without hitting the little icon.

    I shut everything off, (hibernated) becuase I am never sure if I am coming back into the home office after dinner or not, and removed the USB cable cause it was stretched across the floor, where I am sure someone would have tripped over it.
     
  11. Kimelac

    Kimelac Bada Bing! CLM

    Messages:
    433
    Likes Received:
    1
    Joined:
    Dec 16, 2003
    Location:
    fughedaboutit

    This is why I formatted the HD into NTFS, and loaded all the CDs on by hand from the disc. Haven't had to move anything around. And it's all still on the disc, and when I tell iTunes that it's G:\ instead of F:\ it finds it all without a hitch.

    I am just trying to get windows to realize that there is no F:\ - and to stop using the assignment.