Linux sound problem...

Discussion in 'Tech Talk' started by ReyFufuRulesAll, Mar 1, 2007.

  1. ReyFufuRulesAll

    ReyFufuRulesAll Pantless Wonder

    Messages:
    3,066
    Likes Received:
    15
    Joined:
    Oct 30, 2006
    Location:
    Crappleton, Wisconsin
    OK, I got Ubuntu on my computer, and for a while, the sound didn't work.


    After said chunk of time, I updated and the sound started working, but now it's out again!!! I inspected the innards, and found no loose wires.



    Someone help! :help:
     
  2. ReyFufuRulesAll

    ReyFufuRulesAll Pantless Wonder

    Messages:
    3,066
    Likes Received:
    15
    Joined:
    Oct 30, 2006
    Location:
    Crappleton, Wisconsin
    P.S. I am using the onboard sound card of the Asus K8U-X motherboard.
     

  3. IndyGunFreak

    IndyGunFreak

    Messages:
    27,923
    Likes Received:
    3,800
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    Are you getting any errors.. I'm assuming you're not since you didn't mention it.

    First, I'm going to assume you have the "horn" on one of your taskbars(can't remember if its there by default)... If you dont..

    Right Click your bottom Panel
    Click Add to panel
    Drag the "volume" button to the panel(or double click it, whichever you prefer).... Once its there, you can close Add To Panel

    Now that you have the sound icon, do the obvious, check the volume
    Right Click sound icon, Open Volume control, make sure Master and PCM are all the way up, and are not muted on the bottom.

    If that checks out

    Right click your sound icon
    Choose Preferences

    At the top, there's probably gonna be two options in that drop down menu, one will be OSS Mixer, the other Alsa Mixer(you may have 3, like if you have a TV Tuner)...

    You're probably currently set to Alsa Mixer, try setting it to OSS Mixer.

    Test your sound.

    IGF
     
  4. ReyFufuRulesAll

    ReyFufuRulesAll Pantless Wonder

    Messages:
    3,066
    Likes Received:
    15
    Joined:
    Oct 30, 2006
    Location:
    Crappleton, Wisconsin
    OK, if I press the sound icon, I get a popup that says:

    No volume control GStreamer plugins and/or devices found.



    If I right-click the icon and select "properties", nothing happens; I don't even get a popup.
     
  5. IndyGunFreak

    IndyGunFreak

    Messages:
    27,923
    Likes Received:
    3,800
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    Strange.... Seems you need to install the drivers for the sound device... I've never had to do that...

    Open a Terminal
    enter "lspci" no quotes.

    its gonna spit out some junk about your systems PCI devices(you have onboard sound, but its still on the PCI bus)...

    Look through there, and see if it lists your sound device...

    for instance, mine is Multimedia audio Controller: Via Technology, etc..

    IGF
     
  6. ReyFufuRulesAll

    ReyFufuRulesAll Pantless Wonder

    Messages:
    3,066
    Likes Received:
    15
    Joined:
    Oct 30, 2006
    Location:
    Crappleton, Wisconsin
    00:04.0 Multimedia audio controller: ALi Corporation M5455 PCI AC-Link Controller Audio Device (rev 20)


    Is that it?


    Now what?
     
  7. IndyGunFreak

    IndyGunFreak

    Messages:
    27,923
    Likes Received:
    3,800
    Joined:
    Jan 26, 2001
    Location:
    Indiana
  8. ReyFufuRulesAll

    ReyFufuRulesAll Pantless Wonder

    Messages:
    3,066
    Likes Received:
    15
    Joined:
    Oct 30, 2006
    Location:
    Crappleton, Wisconsin
    Well I did what it said and rebooted.


    I was greeted by the sound of these weird african drums, and I did a little dance around my room (i've been trying to figure out the sound problem ALL DAY) in excitement, then got yelled at for making all the noise.



    THANK YOU !!!

    It works now!!!
    :cheerleader: :cheerleader: :cheerleader:
     
  9. IndyGunFreak

    IndyGunFreak

    Messages:
    27,923
    Likes Received:
    3,800
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    No prob, Glad it worked....

    By the way, the wierd african drums..lol, thats the Ubuntu start up tone...

    IGF
     
  10. ReyFufuRulesAll

    ReyFufuRulesAll Pantless Wonder

    Messages:
    3,066
    Likes Received:
    15
    Joined:
    Oct 30, 2006
    Location:
    Crappleton, Wisconsin
    I know, that's why I tdanced!

    :teddy: :wiggle: :snoopy: :running: :rollsmiley: :pepper: :jumprope: :dancing: :bunny: :broccoli: :banana: :bluesbrothers: :cheerleader: :dancingbanana: :exercise: :jumpingjacks: :rock: :workout: :kilt: :horsey: