close

Privacy guaranteed - Your email is not shared with anyone.

Linux & KVM switches

Discussion in 'Tech Talk' started by Trace, Nov 11, 2006.

  1. Trace

    Trace Army Strong Millennium Member

    Joined:
    Apr 16, 1999
    Messages:
    5
    Likes Received:
    0
    Location:
    North Central Texas
    Am I to assume that there isn't a Linux program out there that likes to play nice with a KVM switch? I've tried RedHat, Mandrake, Mepis, and Slackware. None of them like to be on a KVM. When I switch to another system on my 4 port box, and then go back to my Linux box, the mouse just flies all over the screen and appears to be clicking on anything it wants to. The keyboard works fine, and the video is normal.. its just that mouse thing. Any help?
     
  2. biblefreak

    biblefreak

    Joined:
    Mar 4, 2003
    Messages:
    179
    Likes Received:
    0
    Location:
    West Texas
    I had a Belkin KVM switch that did that on a proprietary embedded OS on a DVR that I am fairly certain was *nix based and the solution was hold the button on the KVM switch down a little longer. If you just tapped it it would go nuts everytime, but hold it down a good 2-3 seconds and it worked great!

    Justin
     

  3. Philipp2

    Philipp2

    Joined:
    May 23, 2006
    Messages:
    138
    Likes Received:
    0
    Location:
    Texas
    Have you considered not using the KVM for the mouse? Just plug in a second mouse directly.
     
  4. Trace

    Trace Army Strong Millennium Member

    Joined:
    Apr 16, 1999
    Messages:
    5
    Likes Received:
    0
    Location:
    North Central Texas
    Yeah, I did that before I got the magic cable for my laptop that's on my KVM. Now I plug the Keyboard and Mouse into the magic cable, and then the cable into the ONLY PS/2 port on the laptop. What do you suppose is causing this type of behavior with the switch on my Linux box? I know it worked on the KVM before in that configuration because that box used to have Win2K Pro on it. BTW, I'm using a Microsoft Optical Mouse on the KVM.
     
  5. Tennessee Slim

    Tennessee Slim Señor Member CLM

    Joined:
    Apr 14, 2004
    Messages:
    4,413
    Likes Received:
    0
    Location:
    Mucus City, USA
    Something similar to this fixed the KVM switch on an older Red Hat distro I was working with. Edit the XF86Config file to this:

    Protocol "IMPS/2"
    ZAxisMapping 4 5
     
  6. KG4IDA

    KG4IDA

    Joined:
    Jul 4, 2002
    Messages:
    245
    Likes Received:
    0
    Location:
    East Tennessee
    I am using Suess 9.1 on a KVM switch (a Justcom from CompGeeks)with no problem. I am having the same described problem with a 98 box on that switch but the Linux box and the XP box are fine.
     
  7. Trace

    Trace Army Strong Millennium Member

    Joined:
    Apr 16, 1999
    Messages:
    5
    Likes Received:
    0
    Location:
    North Central Texas
    Um, just FYI... I'm SERIOUSLY Linux stupid. I have no idea what you just typed, or where that's supposed to go. I downloaded Firefox 2.0 onto it, but I have spent the last 4 hours trying to figure out how to install it. It's still not installed.

    By the way, if it matters, I'm using SimplyMEPIS v2004.06
     
  8. Tennessee Slim

    Tennessee Slim Señor Member CLM

    Joined:
    Apr 14, 2004
    Messages:
    4,413
    Likes Received:
    0
    Location:
    Mucus City, USA
    Trace, this is not rocket science but it does require a small bit Leenuks of skill. I probably can coach you through finding the file and I probably can coach you through editing it accordingly, but Murphy’s Law is in effect. Any chance you can find someone who’s *NIX-savvy to help you with the clerical stuff?