close

Privacy guaranteed - Your email is not shared with anyone.

latest Ubuntu 9.10 update wireless problem

Discussion in 'Tech Talk' started by g29andy, Mar 8, 2010.

  1. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Both my dell laptops (Vostro 1400 and Vostro 1500) are dual boot with XP Pro and Ubuntu 9.10. After the latest update, cannot connect wirelessly. It asks me to enter my WPA2 passkey but doesn't connect. Both are able to connect in XP Pro.

    Anyone else have this problem?
     
  2. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Also, booting into the previous version of 9.10 doesn't fix the problem.
     

  3. IndyGunFreak

    IndyGunFreak

    Messages:
    26,899
    Likes Received:
    2,275
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    What is your wireless device?

    Open a terminal and type "lspci" then hit enter(thats a lowercase L)... You should see your wireless device there....

    IGF
     
  4. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    I'll check this evening I think they are intel bgn cards. They worked with jaunty and all previous koala versions until this latest update
     
  5. Linux3

    Linux3

    Messages:
    1,399
    Likes Received:
    0
    Joined:
    Dec 31, 2008
    I have seen this problem before. It was a mash up of the keyring password for wifi.
    Take a look at this site for deleting your password then you can either create a different one or just drop the password.
    http://maketecheasier.com/auto-unlock-keyring-manager-in-ubuntu-intrepid/2009/03/14
     
  6. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Thank! Will try that tonight.
     
  7. TBO

    TBO Why so serious? CLM

    Messages:
    53,802
    Likes Received:
    38,058
    Joined:
    Dec 21, 2002
    Location:
    1504 South 7th Street, Minneapolis, MN 55454
    Mine did the same thing, but I rebooted it and it worked fine.

    Edit- I have an EEE netbook.
     
    Last edited: Mar 9, 2010
  8. IndyGunFreak

    IndyGunFreak

    Messages:
    26,899
    Likes Received:
    2,275
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    Man, you guys are horridly unlucky... I've not had to do anything to my wireless since the first time I installed, including multiple kernel updates...

    IGF
     
  9. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Well, I tried Linux3's suggestion, no dice. Did a clean install of ubuntu 9.10, still cannot connect wirelessly, still asks for my wpa2 password, attempts to connect, then asks for my wpa2 password again.

    My wireless cards are Intel 4965AGN. Somehow the latest update screwed it up so that even a clean install doesn't allow wireless connectivity to my home network on either laptop. Haven't tried another network away from home yet. Will keep digging.
     
  10. IndyGunFreak

    IndyGunFreak

    Messages:
    26,899
    Likes Received:
    2,275
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    It's seeing networks?

    Edit: Ok, its obviously seeing networks... I've found a couple of suggestions on how to fix it... Below seems the most productive, this seems to be a particular issue relating to Dell Laptops.

    http://ubuntu-virginia.ubuntuforums.org/showthread.php?p=8879416

    Post 3 seems to have the fix..

    IGF
     
    Last edited: Mar 9, 2010
  11. IndyGunFreak

    IndyGunFreak

    Messages:
    26,899
    Likes Received:
    2,275
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    TBO.. your problem sounds different... If it continues to do this....

    Right click your Networking Applet
    Choose "Edit Connections"
    On the "Wired" tab, highlight your eth0 connection
    Click Edit
    At the top, uncheck "Connect Automatically"

    Do the same thing on the "Wireless Tab" but make sure "Connect Automatically" is checked.

    Sometimes, especially when a new kernel is loaded... When you boot up, it will spend a few minutes trying to pick up the default eth0 connection.... By removing eth0 from the connection process at startup, it will automatically skip the wired connection, and go right to the wireless.

    I used to have to do that on any clean install, or my wireless would take forever to pick up. Finally, I just got in the habit of it being one of the first things I done on a new install.

    If it only done it that one time, its probably nothing to worry about, but if it starts doing it a lot,, that should fix it...

    IGF
     
    Last edited: Mar 9, 2010
  12. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    IGF, I found that solution and tried blacklisting before I tried Linux3's suggestion. Didn't fix the problem. I'll try removing dell-laptop now that I've clean installed 9.10.
     
  13. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Doesn't work with deleting dell-laptop either. Maybe a fix will be released soon, looks like this latest update somehow screwed it up. Will have to use xp for now.
     
  14. IndyGunFreak

    IndyGunFreak

    Messages:
    26,899
    Likes Received:
    2,275
    Joined:
    Jan 26, 2001
    Location:
    Indiana
    It's strange, the Intel's were always so well supported, and the last two versions, they've been having some real issues....

    I would try a couple of things before giving up...
    1st... I would log into the router, and remove all security settings(ie, open network)... and see if you can connect. Then if you can, gradually work back, until you can't.

    2nd... would be trying to use the Windows driver, to get the device to work w/ Ndiswrapper. I've never used Ndiswrapper, so I can't really guide you on that... but I'm fairly certain you'll have to blacklist the Intel driver, so that it won't load on startup, then setup ndiswrapper to see the Windows Intel Driver, and set ndiswrapper to load at startup...

    IGF
     
  15. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Aha! With no wireless security enabled, I have a connection. No connection with WPA-TKIP or WPA AES. I didn't try WEP as it is basically an open network. Had been using WPA2-AES forever, but apparently the latest 9.10 update has some issues with it.

    However, I've re-enabled WPA2-AES and will use XP Pro until there is a fix for this, don't want to leave my network open for the neighbors.
     
    Last edited: Mar 9, 2010
  16. Linux3

    Linux3

    Messages:
    1,399
    Likes Received:
    0
    Joined:
    Dec 31, 2008
  17. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Hope that's it, will check router channel this evening. Thanks fellas!
     
  18. StuntPilot

    StuntPilot

    Messages:
    146
    Likes Received:
    5
    Joined:
    Oct 22, 2006
    Location:
    DFW, TX
    I love Ubuntu, but the wireless support can be troublesome. I had a Dell 710m laptop that needed NDISwrapper, but Ubuntu 9.10 sometimes finds restricted drivers that must be activated

    Please try this:

    Option 1 - Linux wifi drivers
    • On the Ubuntu menus, click on system/administration/hardware drivers
    • Your laptop will search the driver store for a minute or two
    • Hopefully, it will display some sort of 'wireless driver' that needs to be activated
    • Click on the driver, and then click activate
    • reboot
    • the wireless card should work
    Option 2 - NDIS Wrapper

    NDISwrapper uses the windows wireless drivers to activate the wifi card under linux

    Install NDISwrapper
    • Download the windows drivers for the wifi card to your linux laptop
    • Extract the download file to a directory on the hard drive
    • You need the .inf and .sys file, make sure they are in the same directory
    • Click on system/administration/synaptic package manager
    • Type ndis in the quick search box
    • Select ndisgtk, ndiswrapper-utils-1.9, and ndiswrapper-common for installation
    • Click apply twice
    Configure NDISwrapper
    • click on system/administration/windows wireless drivers
    • click on install new driver
    • browse to the location of the .inf file, and select it
    • click open
    • click install
    • The system should display the driver, and say hardware present 'yes'
    • click close
    • reboot
    • cross your fingers ;-)

    Additional resources:

    https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

    http://linuxwireless.org/en/users

    http://intellinuxwireless.org/?n=Downloads
     
  19. g29andy

    g29andy CLM

    Messages:
    2,743
    Likes Received:
    142
    Joined:
    Jan 28, 2001
    Well, my router only has channels 1-11, which should be supported.

    No wireless driver options show up with "hardware drivers". Shouldn't there be one already since everything was working fine from 8.04 up until now? Also since if I disable wpa2 security, I can connect fine. Haven't changed security keys or anything.

    I guess I can try ndiswrapper, but have never had to use it before this last 9.10 update. I wonder if rolling back to the last LTS ubuntu version would work.
     
    Last edited: Mar 10, 2010
  20. StuntPilot

    StuntPilot

    Messages:
    146
    Likes Received:
    5
    Joined:
    Oct 22, 2006
    Location:
    DFW, TX
    I am sorry you are having the problem. I could never get wireless to work on my Dell 710m without using NDISwrapper. When I looked on ubuntuforums.org, there were plenty of folks with the same issue...because of the Broadcom wireless card. I saw you already posted in the Wireless and Networking forum. Someone will probably figure out what update jammed up your machine.

    You could always uninstall NDISwrapper, once a fix is determined.