close

Privacy guaranteed - Your email is not shared with anyone.

Kimber FTF issues after spring change

Discussion in 'Gunsmithing' started by detroit9mm, Nov 9, 2011.

  1. detroit9mm

    detroit9mm

    Joined:
    Mar 17, 2008
    Messages:
    132
    Likes Received:
    0
    I recently acquired a used Eclipse Pro II. I took it out and ran 100 rds thru it with the stock mag and a Wilson Combat. I had 3 minor FTF on the stock mag and no issues with the Wilson. Because I got the gun used I ordered the Wolff XP spring kit for it and installed. I took it out tonight (first time since spring change) and i cant get thru a single mag without at least one FTF. The only thing that changed since the last range trip is the springs so it seems to reason that has to be the issue but i thought those springs were supposed to be an upgrade. Anyone else have this issue and is there some other reason explanation the pistol would all of a sudden be a jam-o-matic? i really like the look and accuracy of it so I'd like to make it reliable if possible.
     
  2. luscioman

    luscioman

    Joined:
    Mar 3, 2005
    Messages:
    45
    Likes Received:
    0
    Location:
    FL

  3. cciman

    cciman

    Joined:
    Jan 19, 2009
    Messages:
    3,726
    Likes Received:
    214
    Location:
    SW Ohio
    You are not really describing how the gun is FTF.

    I use the Wolf XP springs and have had no issues.
     
  4. greco2009

    greco2009

    Joined:
    Apr 15, 2009
    Messages:
    25
    Likes Received:
    0
    Which FTF..??

    Fail to feed
    fail to fire
    fail to function???