Glock Forum - GlockTalk banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,
I recently built a polymer 80 and have had some setbacks to having the build 100 percent functional. Firstly, when I completely assembled the build, the trigger wasn't disconnecting, I would completely pull the trigger and the striker wouldn't release. So I read on another forum, a guy said the sear may need a little adjusting, So I ever so slightly bent it down, maybe half a millimeter. I re-assembled the pistol, and it worked !
Then when I racked the slide it would reset the trigger...But only when I had very little pressure on it or I wasn't touching it. but if I pull the trigger and keep the full amount of pressure on it, it still wont reset.
 

·
Registered
Joined
·
445 Posts
Hi,
I recently built a polymer 80 and have had some setbacks to having the build 100 percent functional. Firstly, when I completely assembled the build, the trigger wasn't disconnecting, I would completely pull the trigger and the striker wouldn't release. So I read on another forum, a guy said the sear may need a little adjusting, So I ever so slightly bent it down, maybe half a millimeter. I re-assembled the pistol, and it worked !
Then when I racked the slide it would reset the trigger...But only when I had very little pressure on it or I wasn't touching it. but if I pull the trigger and keep the full amount of pressure on it, it still wont reset.
Sounds dangerous to me.
 

·
Registered
Joined
·
682 Posts
Are you running an aftermarket slide or an OEM setup?

I am, and have been, running a complete OEM Glock upper on mine from the get go. Just over 400 rds with no issues...other than it does not like to run the 31 rd magazines because of the grip angle...17s run fine...

Every issue I have seen has been from people using aftermarket slides. Not to say they won't work and do for a lot of guys out there. However it seems to me that aftermarket uppers require a bit more tuning.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Are you running an aftermarket slide or an OEM setup?

I am, and have been, running a complete OEM Glock upper on mine from the get go. Just over 400 rds with no issues...other than it does not like to run the 31 rd magazines because of the grip angle...17s run fine...

Every issue I have seen has been from people using aftermarket slides. Not to say they won't work and do for a lot of guys out there. However it seems to me that aftermarket uppers require a bit more tuning.
Im using an after market slide, its by Swenson.
 
1 - 5 of 5 Posts
Top