Glock Forum - GlockTalk banner
1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
g19 gen4 bought new never an issue until last week.
stovepipes and failure to feed. running white box and
hornady critical defense . round count 1500 + . any
thoughts or send to LGS. ty
 

·
Registered
Joined
·
458 Posts
I'd try detail stripping and cleaning slide. Inspect extractor hook to see if its chipped. Clean extractor plunger channel.

Did the problems start mid-session, or at start of session after you had it apart to clean after last session? Is the little plastic knob installed on back of the extractor spring?
 

·
Registered
Joined
·
3,491 Posts
Believe or not, I would think ammo. WW White box is lightly loaded stuff, and Hornady Critical D is a light bullet. But w/o knowing anything else, that is a WAG.
Weapon may need a detail cleaning like yep380 & ChillyB stated. Again, a WAG.
 

·
Registered
Joined
·
841 Posts
g19 gen4 bought new never an issue until last week.
stovepipes and failure to feed. running white box and
hornady critical defense . round count 1500 + . any
thoughts or send to LGS. ty
Stovepipes: Check extractor; on the other side, is your ejector bent leftwards/away from the ejection port?
FtF: Did you switch to non-OEM magazines?
 

·
Registered
Joined
·
1,734 Posts
Have the same gun and have never experienced what you have. Not knowing your experience, make sure that you are gripping it firmly. Not gripping it correctly may cause your issues. Also, like it has been mentioned, do a detail cleaning and do check the extractor for chipping. Looking at the ejector from the front of the frame, the tip of it should be tilted to the left. As for ammo, I stay away from WWB and use Federal, Fiocchi, S&B new brass FMJ for target and Federal HST for SD.
 

·
Registered
Gen 5 Glock 19 MOS FS
Joined
·
4,117 Posts
g19 gen4 bought new never an issue until last week.
stovepipes and failure to feed. running white box and
hornady critical defense . round count 1500 + . any
thoughts or send to LGS. ty
If you have run 1500 + of this ammo already, I second that you might check your extractor and give it a good cleaning. Gunk can build up underneath it. Have you been using the same magazine? Sounds almost like a magazine spring problem. Switch magazines and see if that helps matters.
 

·
Registered
Joined
·
458 Posts
Good point on mags. I numbered mine to track any malfunctions until everything was established as reliable. Until getting rid of 336 ejector it helped me to eliminate mags because ALL mags performed equally poor.
 
1 - 10 of 10 Posts
Top