Glock Talk banner

Extraction ejection Issues.

2002 Views 45 Replies 12 Participants Last post by  Jammersix
I have a Kimber Pro II that has been giving me some problems.

Originally it would not feed or eject worth a darn. Ball ammo was the best and Semi-wadcutters were the worst.

I just installed a Wilson Combat extractor and a 22 lb recoil spring.

I took it out this morning for a test run.

The 230 Ball fed without issue, the Semi-wadcutters still no go.

Now that it will reliably feed the Ball I still have an ejection issue.

The brass ejects in every direction and not very far. Some goes right a foot or two, some goes left a foot, some even goes forward a foot or two, but most "still" ejects right into my face or bounces of the brim of my hat.

If the extractor was not the problem, what is the cause and how can I fix this?

Thanks
1 - 4 of 4 Posts

· Registered
Joined
·
3,427 Posts
SWC bullets so reloads ?? PL is to low or springs to heavy . OAL of cartridge is to short or to long maybe even amount of crimp . I have a 200gr swc load with OAL of 1.235 that feeds in a number of 45acp kahrs 1911's ruger my friends or I have including a new commander with a 20lb spring . maybe you should let a more experienced 1911 guy give it a try . My wifes kimbers a running machine .

Guess You have had the extractor tension checked and looked for any burns and sharp bottom edge to the extractor that could be smoothed .
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top