close

Privacy guaranteed - Your email is not shared with anyone.

can't get modem to work in linux

Discussion in 'Tech Talk' started by David_G17, Sep 24, 2004.

  1. David_G17

    David_G17 /\/\/\/\/\/\/\/

    Messages:
    2,046
    Likes Received:
    6
    Joined:
    Oct 7, 2002
    edited to add: i got it working. i was trying /dev/modem instead of /dev/ttyS0. i should have been able to symlink it, but i screwed that up some how.

    i have an external serial modem which is supposed to work in linux (i even saw a guy using it in SUSE). i'm running fedora core and i'm having trouble setting it up.

    at first, i didn't have the serial port enabled in the bios, i fixed that, but i'm still having problems.

    i read somewhere that i should be able to "cat /proc/interrupts" and i should see "serial" listed there. I don't see it; is there any other way to determine if my serial port is working?

    according to one guy who was having the same problems i'm having setserial fixed it. i ran "/bin/setserial -b /dev/ttyS0 IRQ 4". could this mess anything up? when i activated my serial port in the bios, it said it was on IRQ 4.

    any help/ideas are appreciated.

    thanks.
     
  2. David_G17

    David_G17 /\/\/\/\/\/\/\/

    Messages:
    2,046
    Likes Received:
    6
    Joined:
    Oct 7, 2002
    well, i now know the modem works. i got it up and running in like 2 minutes using a knoppix disc.

    anyone know how to do it in fedora?
     

  3. HerrGlock

    HerrGlock Scouts Out CLM

    Messages:
    23,802
    Likes Received:
    255
    Joined:
    Dec 28, 2000
    # setserial /dev/ttyS3
    /dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3

    COM 4 Doesn't exist on this machine (note unknown)

    # setserial /dev/ttyS2
    /dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4

    COM 3 Doesn't exist on this machine.

    # setserial /dev/ttyS1
    /dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3

    COM 2, standard serial port with the 16550A

    # setserial /dev/ttyS0
    /dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4

    COM 1 again standard serial port.

    cd /dev
    rm -f modem
    ln -s ttyS0 modem #Makes modem COM 1
    (try minicom see if it can open modem)
    rm -f modem
    ln -s ttyS1 modem #Makes it COM 2

    minicom will set up the com port to as high as it can go if you do the help page and set the com port up. Exit without reset afterwords, try it and if it works with those settings, you can use setserial to make sure it goes back to them upon reboot.

    DanH
     
  4. David_G17

    David_G17 /\/\/\/\/\/\/\/

    Messages:
    2,046
    Likes Received:
    6
    Joined:
    Oct 7, 2002
    that's what i was looking for.;c

    i was afraid to rm /dev/modem.

    thought my computer might catch on fire or something.
     
  5. Tennessee Slim

    Tennessee Slim Señor Member CLM

    Messages:
    4,413
    Likes Received:
    0
    Joined:
    Apr 14, 2004
    Location:
    Mucus City, USA