Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Forum at

Why should YOU join our forums?

  • Reason #1
  • Reason #2
  • Reason #3

Site Description

What I done the last few days -- LONG RANT

Discussion in 'Tech Talk' started by IndyGunFreak, Aug 3, 2011.

  1. IndyGunFreak


    Jan 26, 2001
    What a last few days...

    First, how could FreeNas, which was so awesome in Version .6, SUCK SO BADLY in version 8?

    Here's how my little adventure began, 3 days ago. Was helping an internet friend w/ some FreeNas 8 issues. I've been using .6 for a while, w/o issue.. There were apparently a lot of changes between the two, so I backed up my config, downloaded 8, and booted it, in an effort to help him work through his problem. Now, a smart person, would have used a different USB, so I'd still have my settings. I figured "Meh, this'll be easy, and I'll have this set up in 20min, like I did last time.. and besides that, I had my configuration backed up"... sometimes, I think it's just meant that I am to be At least I was smart enough to make sure everything on the NAS disks, was backed up externally.

    Spent SEVERAL HOURS working w/ my friend on his problem, with no joy. He finally gave up on it, but I pressed on, trying to get MY BOX running. Constant permission errors, failing to mount (in both Windows and Linux), drives mysteriously not there, etc. Then the best one, FreeNas reported a drive that was "Online", but said there were files system errors, and it could not be Again, this is not rocket science, I set up .6 in about 25-30min tops.

    As of about 10hrs ago, this was my 3rd DAY trying to get this working, 2 full days off, and one all nighter, spent trying to get this to work. It still didn't work properly! I had spent about 25hrs in the support channel (I'm assuming this must be a joke)... One person suggested downloading to 7.2 .. OK.. it's worth a shot... for some strange reason, it wouldn't even boot. Worked on that one for a few hours. About Noon today, someone suggested trying 8.01 Beta 4, as it fixed a lot of "issues" that were in the 8.0 final release... Worth a shot.. No joy there either. Now, most of you know, I'm a Linux user, and I understand the idea behind "community support".. but everyone coming into this channel for help was told to "fill out a bug report" and I saw multiple people with issues similar to mine.

    Now, you say... "Why not just reinstall FreeNas .6, since it worked well for you, and you had your configuration backed up for it?" Well, My FreeNas .6 CD, was mysteriously missing in action (still not sure where it is) and on FreeNAS's homepage, all they have available for Download, is 7 and 8 (both of which were giving me TONS of probs)

    By 4pm, had whoever wrote FreeNas 8 been sitting beside me, he'd likely be hospitalized at this moment. I took a quick look at a FreeNAS "Alternative" called OpenFiler.. Got rave reviews, etc. It was OK... I didn't like it all that much, but I will say, it did work. If you're gonna have a GUI, it should at least be an intuitive one... OpenFiler's was awful (or maybe I was to use to the FreeNas WebGUI)

    So around 11pm, I'm bordering on furious this is still an issue for me, and I decide, "You know what, screw it, I'll install Ubuntu Server" and just set up file server that way. Unfortunately, I'm not that familiar with Ubuntu's server distros, and I knew I'd be doing a lot of Googling. So rather than just immediately sticking it on the server, I decided to try it in Vbox (3 virtual drives, 1 6gig (to simulate the USB I'll install to), and 2, 10.0gig "storage drives.) Get everything installed, get the RAID 1 set up on my two "storage drives", samba, ssh, etc. All while taking extremely detailed notes. I finish to what I feel is an acceptable setup, that is actually working quite well, with Vbox, about 20min ago (it's 1:45am here in case you're curious)...

    Oh well, at least I "KNOW" what will fix it. I'll roll this to the server either tomorrow or Thur., then next time someone needs help, I'm just keeping my MOUTH SHUT!.. ;)

    Thank you for listening... I really do feel better.. :)

    Last edited: Aug 3, 2011
  2. Pierre!

    Pierre! NRA Life Member

    Jun 20, 2003
    Lovin Sparks Nv!
    I have a gross of those t-shirts - says 'I just been humbled' if you want a few extras... :rofl:

    I'll be nice an not send any that have Windows goo on them, or blood (mostly my blood)..

    Love that humbling thing... It's very effective.

    I see 'Humble' comin, I run!

    Glad to hear you got the work around figured out! See it WAS a productive 2.5 days crammed into only 2 actual days.

    Rest Well,
    God Bless


  3. JimmyN


    Sep 29, 2006
    iXsystems took over development of FreeNAS starting with version 8, and they switched from the m0n0wall base to a nanobsd base, a complete rewrite from scratch. It's still missing a lot of the features found in version .7, and the last I read version 8 still wasn't recommended for production use. The final BETA version was only released a few weeks ago in mid July.

    The version number was changed to reflect the FreeBSD version it is based on, thus the version jumped from the incremental .6.xx, .7.xx series all the way to 8.xx as iXsystems is using FreeBSD 8. But they created a big problem as iXsystems changed from using hard wired device names in the database to identifiers, so upgrading from .7 to 8 is not recommended as you'll probably lose your drive configuration or your data, or more likely both. There is no way to import your configuration from .7 to 8 as they also changed from the simple php based startup used in .7 to the FreeBSD rc.d boot system.

    The minimum install space with version 8 is now 2gigs, rather than 128megs. And the OS has to reside on it's own drive, you can no longer partition it for a data space, nor can you do any shares from the boot drive since it can contain only one slice used for the OS. You can still boot from a CF adapter or thumbdrive, but they have to be at least 2gig capacity.

    Personally I consider version 8 to be a tub of excrement that they pushed out way too early. Missing features, bugs, and incompatible with earlier versions. Since version 8 is a completely different animal from earlier versions you can't switch back and forth between versions to try it, unless you want to back up all your data drives so you can restore the data when you change versions.

    I intend to stick with .7.xx and development will continue by the FreeNAS team to an anticipated final version .7.4 release. IXsystems version of FreeNAS will be numbered 8.xx and up. So there are two trunks, the 8.xx by iXsystems and the .7.xx by the original FreeNAS team.

    Any version .7.2 with a build number of 5543 or greater is secure. There was a vulnerability discovered in builds 5542 and earlier, in that if you had the webgui open with Quixplorer in one tab and accessed a web site that had a malicious script specifically attempting access to FreeNAS they could gain root permission through the webgui. But that was a pretty remote possibility, and by only allowing webgui access from a specified IP as I do it couldn't happen anyway.

    It looks like the .6.xx versions are no longer available, I couldn't find any either except for some torrent sites. All I have are .7.1 and .7.2 versions. If you do get it from a torrent site SourceForge still has the MD5 iso sums listed under "Revisions" for the .6.xx versions so you can check your download.
  4. jasonvp

    jasonvp Kantre Member Lifetime Member

    This is why my NAS is running CentOS 5.5. It's more server than I need and there is a lot of extra cruft that gets installed. I just disabled all the extra stuff (ya know what? My NAS doesn't need sendmail running, thanks bye) and used mdadm to create my RAID10 volume.

    NFS for the Linux clients in the house, SMB for the Windows clients in the house, and AFP compiled and running for the Macs. Done.

  5. IndyGunFreak


    Jan 26, 2001
    Man, that's pretty disappointing. I really liked FreeNas, and I wondered how it began to suck so badly. If I had been able to find my .6 CD, this would have all been a non-issue.

    I wasn't aware there was a "takeover" of FreeNas, but I figured something had changed. Maybe the original FreeNas team will get together and create another quality open source option.

    Ubuntu Server, during Install, lets you choose what "services" you want to install. Since I didn't need sendmail, etc.. I didn't install them. All I installed was OpenSSH and Samba, then set up the RAID for my storage drives. Samba is easy enough to configure, I don't mind setting it up on our Linux boxes. I've never set up NFS, but it can't be that difficult.

    Interesting you bring this up, cuz I hadn't checked to see exactly how much space it was taking up on the 6gig "OS" virtual drive I set up. I just fired up the virtual machine to check, and my system is completely up to date with system updates, all the utilities I need are installed and configured, etc.. and the entire install is less than 2gigs. That's including a 1gig swap!

  6. Linux3


    Dec 31, 2008
    IGF, I have been setting up NFS and NIS servers for years on SGI, Solaris and a few Linux distros.
    If you have a question let me know.

    I'm a big CentOS fan and have not used Ubuntu server but NFS is NFS.
  7. jasonvp

    jasonvp Kantre Member Lifetime Member

    The CentOS installer lets you get that detailed if you want. It actually seems to take longer to do that, than it does to just let it install the base "Server" install, and then go through and remove what you don't want. It's not a difficult process either way.


    You're using Linux, a UNIX variant, and you've never configured NFS?! Holy... M'boy, you have a lot to learn. :)

    I assume you don't intend to run your full-time NAS out of a VM, right? This was just for testing and validation purposes? My home made NAS has a single 80G drive in it for the OS, which is about 75G larger than it needs to be. But it was cheap, and I wanted the OS on a completely separate media from the exported volume.

    bane$ df
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda3              69G  3.7G   62G   6% /
    /dev/sda1              99M   24M   71M  25% /boot
    tmpfs                1006M     0 1006M   0% /dev/shm
                          2.7T  776G  1.8T  30% /opt
    /opt is what I'm exporting via NFS/SAMBA/AFP. I can nuke the OS at any time and install something new if I want. Like Linux3 said, I'm also a big CentOS fan. I use it for my router, my NAS, and I have several VMs of it running at home (including a new CentOS 6 VM). Ask away if you have any questions.

  8. IndyGunFreak


    Jan 26, 2001
    Never really had the need for it to be truthful. I'm not the type of person who goes out of my way to learn something, just because I should.. :) (although that is kinda what got me into this mess)

  9. Linux3


    Dec 31, 2008
    I make /home a separate partition.
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/sda1 50395844 6235296 41600548 14% /
    /dev/sda3 422262304 29077764 371734864 8% /home
    /dev/sdb1 480720592 315626412 164117412 66% /Data
    cat /proc/swaps
    Filename Type Size Used Priority
    /dev/sda2 partition 8191996 0 -1

    If I have to nuke the OS anything in /home is not touched. I can copy config files and stuff into /home.
  10. jasonvp

    jasonvp Kantre Member Lifetime Member

    It's possible I thought of that already... :)

    bane$ ls -latd /home
    lrwxrwxrwx 1 root root 9 Dec 15  2009 /home -> /opt/home/
  11. IndyGunFreak


    Jan 26, 2001
    Appreciate the offer, but I have it under control at this point.. It's just a matter of implementing what I've done in Vbox into my server... I just deleted all my configurations, etc.. and went through, reinstalled the Server, and set it up in Vbox again, following my notes, and it went w/o a hitch. Unless my server has some sort of hardware issue w/ Ubuntu Server (very unlikely) I don't anticipate a problem.

    FWIW, One of the reasons I use Samba, is because on occasion my sister has put family photos, etc.. on the NAS w/ her Windows laptop. I've never set up NFS, but I imagine if I really wanted to (I did some reading on it).. I could do it w/o issue.

    Samba, I'm just familiar with it, know how to set it up pretty much w/ my eyes closed, and it works fine... :). This is really the reason I chose Ubuntu Server, rather than Centos... I'm just a lot more familiar w/ how Debian based distros work.