close

Privacy guaranteed - Your email is not shared with anyone.

What did I do wrong? (extended slide release install)

Discussion in 'Gunsmithing' started by DeltaCO, May 24, 2011.

  1. DeltaCO

    DeltaCO

    2
    0
    Aug 17, 2010
    A couple of days ago I installed a Glock extended slide release on my G17 Gen3. It seemed to go well. Yesterday I was at the range to test it, and the slide was locking back after every shot. What did I do wrong?
     
  2. ChrisJn

    ChrisJn "Old Bill"

    1,838
    119
    Dec 30, 2008
    Baldwin Co, Alabama
    I assume you mean an extended slide stop lever. If so you have put back the pins in the wrong order.
     

  3. fastbolt

    fastbolt

    12,090
    3,286
    Jun 9, 2002
    CA Central Coast
    At a guess, it sounds like when you replaced the slide stop lever you unintentionally trapped the end of the slide stop lever spring above the locking block pin (instead of below it, where it belongs), and probably did so by installing the locking block pin after the lever was positioned in the frame. This can easily happen if someone forgets to install the locking block pin before they install the slide stop lever.
     
  4. GunHo198

    GunHo198

    1,120
    0
    Oct 7, 2004
    Tampa
    X2 What they said.
    Even though I never had an issue, I have been guilty of putting the pins in, in the wrong order. And I can see where this will cause the problem.
     
  5. DeltaCO

    DeltaCO

    2
    0
    Aug 17, 2010
    Thanks! That did the trick.