close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

webgoat

Discussion in 'Tech Talk' started by RWBlue, Jan 29, 2011.

  1. RWBlue

    RWBlue Mr. CISSP, CISA CLM

    23,521
    832
    Jan 24, 2004
    Any webgoat gurus out there?

    I thought I would setup a quick test and I am doing something wrong.
    I have Tomcat installed, but I can not get webgoat to install.
    It has to be something stupid I am over looking, but.....

    Walk me through the big steps, big things I could be missing.
     
  2. tous

    tous GET A ROPE!

    30,295
    24,991
    Jan 7, 2001
    Plano, Texas, Republic of
    It's a .war
    Just moving it to the webapps directory in the Tomcat install isn't working?

    I'd deploy a test .war first to see if Tomcat is functioning correctly.
     


  3. RWBlue

    RWBlue Mr. CISSP, CISA CLM

    23,521
    832
    Jan 24, 2004
    I at the stage where I have the tomcat start page running on port 8080.

    I have not touched tomcat in years. Everything has changed.
     
  4. RWBlue

    RWBlue Mr. CISSP, CISA CLM

    23,521
    832
    Jan 24, 2004
    I am working on this again. This go round I am on a windowsXP virtual machine hosted on Windows7.


    Tomcat is installed and appears to be running ok.
    [​IMG]

    I can get to the manager.
    [​IMG]

    [​IMG]
     
  5. RWBlue

    RWBlue Mr. CISSP, CISA CLM

    23,521
    832
    Jan 24, 2004
    I installed webgoat fresh. I installed the war file.

    It prompts for password as expected.
    [​IMG]

    It will not let me in with the tomcat admin password or the webgoat passwords.
    [​IMG]

    I think I have a permissions issue, but I can not figure out what to change.
     
  6. RWBlue

    RWBlue Mr. CISSP, CISA CLM

    23,521
    832
    Jan 24, 2004
    I installed the admin functions, but not correctly.

    [​IMG]

    I am stuck.

    I am running out of things to check and do.

    Anyone have a good forum to post this information on?
     
  7. RWBlue

    RWBlue Mr. CISSP, CISA CLM

    23,521
    832
    Jan 24, 2004