close

Privacy guaranteed - Your email is not shared with anyone.

vehicle problem

Discussion in 'Car Forum' started by don51181, Nov 18, 2005.


  1. don51181

    don51181
    Expand Collapse

    Joined:
    Jun 18, 2004
    245
    0
    Location:
    Bremerton, WA
    I have a poblem with my 98 Plymouth Grand Voyager. Sometimes when I put it in drive or reverse it just revs the motor. I am wondering if it is the torque converter or the transmission. The engine sounds fine and the shifter is in the correct position. Thanks for any help.
     

    Wanna kill these ads? We can help!
  2. Asha'man

    Asha'man
    Expand Collapse
    eat the eat!

    Joined:
    Jan 13, 2004
    475
    0
    Location:
    Denver
    Slipping tranny. Check your fluid level.

    Brian
     

  3. don51181

    don51181
    Expand Collapse

    Joined:
    Jun 18, 2004
    245
    0
    Location:
    Bremerton, WA
    I checked the fluid level and the problem is still there.
     
  4. Asha'man

    Asha'man
    Expand Collapse
    eat the eat!

    Joined:
    Jan 13, 2004
    475
    0
    Location:
    Denver
    In that case you might be ****ed. It's a Chrysler minivan, after all, which makes it very easy for me to believe that the tranny is on it's way out.

    Brian
     
  5. GLOCK22SHOOTER

    GLOCK22SHOOTER
    Expand Collapse
    NOT A VICTIM

    Joined:
    Nov 17, 2005
    160
    0
    Location:
    Depths of decay,Louisiana
    Sounds like a tranny change is in order
     
  6. don51181

    don51181
    Expand Collapse

    Joined:
    Jun 18, 2004
    245
    0
    Location:
    Bremerton, WA
    After I changed the trans fluid I found a lot of stuff on the magnet in the tras. I guess the fluid was really dirty. After I chaged it the problem went away for the pasy month then it started acting up again. Maybe the fluid is low.