Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Forum at

Why should YOU join our forums?

  • Reason #1
  • Reason #2
  • Reason #3

Site Description

USB Hub Question

Discussion in 'Tech Talk' started by EagleOne716, Dec 13, 2008.

  1. EagleOne716

    EagleOne716 Guest

    Here is the situation:
    1. Running a computer under Windows 2000 Pro
    2. Have a USB 2.0 card installed
    3. Cable running from 2.0 card to a powered USB Port
    4. When I run external CD problem.
    5. When I insert a Kingston DataTraveler 2 GB into the powered hub, it says that there is not enough power to run it.
    6. If I run any other USB thumb problems, just the Kingston. gets better....
    7. I plug a NON-powered USB port into the POWERED port....and the Kingston drive reads/writes with no problem.
    Any suggestions????? Ideas????
    Thanks...EAGLE :wavey:
  2. EagleOne716

    EagleOne716 Guest

    13 viewings....and no idea?
    This must be more complicated that I thought :upeyes:

  3. aspartz


    Oct 19, 2000
    Sandstone, MN 55072
    It sounds like the powered hub is mis-reporting the amperage available at its downstream ports.
    Back when wheels were square I knew how to check this on an os9 mac, os X and windows, i have no clue.

  4. JimmyN


    Sep 29, 2006
    Your using Win2K Pro so do this:

    Start>Settings>Control Panel
    System>Hardware>Device Manager

    Scroll to the bottom and click the '+' to expand "Universal Serial Bus Controllers. Or double click on controllers if you are using an icon Control Panel view

    There you will see all USB devices listed, as well as the hubs.
    Right click on any hub or device and select 'Properties' then the 'Power' tab.

    On this computer I have 4 - USB Root Hubs shown in the list, those are on the motherboard. My external powered hub shows up as "Generic USB Hub"
    Choosing 'Properties>Power' on this device shows the hub as self powered, and has 500mA available per port.
    There are 4 ports available, one is in use using 96mA for a "USB Storage Device" which in this case is an external USB harddrive.

    Maybe that will help you gather a little info on the problem......