close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

USB hard drive weirdness

Discussion in 'Tech Talk' started by JinVA, Aug 7, 2005.

  1. JinVA

    JinVA

    229
    0
    Aug 2, 2005
    SE Virginia
    This is a bizarro problem:
    I have a maxtor one-touch 300gb external and XP pro. Its the USB or firewire version, but I only have USB, so thats what Ive been using.

    I set it up again after driving it across the whole country. It was safely packed in a box and din't get the opportunity to move around or anything.
    When attached It makes the 2 beeps as usual, and the "safely remove hardware" icon appears.
    BUT...the drive does not appear in "my computer". And when I click on the shortcut I had on my desktop direct to the drive...it says " Error! cannot be found "

    I suspected that installing the software for my GPS (also USB) might have done something, so I tried the maxtor on my brand spanking new laptop. Same behavior!

    The "safely remove" thing works, it just wont show up in my computer. Also the maxctor software does not detect the drive whe I try to run diagnostics...

    Dont that beat all...
    any ideas?
     
  2. GTIMANiac

    GTIMANiac

    77
    0
    Jul 14, 2001
    I am guessing for some reason it is not in the same USB port. Go to device manager and see if it appears, if it does check disk administrator and see if it is listed there. I have the same drive and have had no problems.


    right click my computer -> manage
    device manager ->
    look under "storage volumes" and also "disk drives"

    disk administrator is in the same applet under Storage in the left hand pain. the disk may be there and just not have a drive letter assigned to it.
     


  3. prism

    prism more ammo

    1,420
    8
    Sep 26, 2002
    Indiana
    open it up and verify the connectors are still firmly connecting. also verify that the hd is spinning.
     
  4. JinVA

    JinVA

    229
    0
    Aug 2, 2005
    SE Virginia
    It spins just fine. I don't want to take the thing apart since theres a warrantee voided if broken sticker.
    I'll try connecting it to all my USB ports tho.
     
  5. Egyas

    Egyas Troll Hater

    Another thing to consider. Some USB ports (like the ones on the laptop I am using now) are
    "low-voltage" ports. You plug in an external drive, and it spins up but the computer won't recognize it. On my laptop, I cannot use an external drive unless the laptop is in the port replicator and is plugged into one of the ports on the replicator. The ports directly on the laptop itself are too underpowered. If I want to use one of these ports, the external drive MUST have its own power supply.


    Just food for thought.
     
  6. GTIMANiac

    GTIMANiac

    77
    0
    Jul 14, 2001
    The Maxtor 1394/USB drives are powered. They are not passive. So this should not be a problem.

    Did you check Device Manager and Disk Administrator?