close

Privacy guaranteed - Your email is not shared with anyone.

Taurus TCP issue

Discussion in 'General Firearms Forum' started by wnr700, Feb 12, 2012.


  1. wnr700

    wnr700
    Expand Collapse

    Joined:
    Dec 1, 2009
    268
    3
    Location:
    Coast of South Carolina
    My Taurus TCP shoots well so far... about 70 rounds.

    Really liked the gun and recoil wasn't too bad.

    My main issue is it almost impossible to rack a round via pulling the slide back.

    Just loaded a few rounds and was able to load a round. There seems to be a feeding issue. The brass has a rub mark on the body of the brass casing.

    Must lock back slide, insert mag, and press mag release thus loading first round... which I can only describe as a kinda grinding process.

    Is this a typical issue and can it be fixed without sending away to Taurus?
     
    #1 wnr700, Feb 12, 2012
    Last edited: Feb 12, 2012
  2. travis34769

    travis34769
    Expand Collapse

    Joined:
    Mar 12, 2007
    187
    0
    Location:
    orlando
    Yes, I can see them recalling the TCP. This issue is becoming a major problem and I know at least 10 people that are having the same issue. I just got mine back from Taurus. I forgot what the paper said but it is fixed now. Feeding bullets is a major problem with the TCP.
     

  3. ruffhunter

    ruffhunter
    Expand Collapse

    Joined:
    Mar 9, 2009
    168
    5
    Location:
    sw ohio
    I got the same problem with mine. I think the mag spring is too weak and the follower could use a higher pitch.
     
  4. NEOH212

    NEOH212
    Expand Collapse
    Diesel Girl

    Joined:
    Mar 25, 2008
    8,983
    11
    Location:
    North East Ohio
    What did you expect? It is a Taurus after all. :rofl:

    Do yourself a favor. Buy a real gun and dump the junk.