close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

Sent conversion kit back. Still have problems.

Discussion in 'General Glocking' started by theflatlander, Nov 9, 2012.

  1. theflatlander

    theflatlander

    88
    0
    Apr 19, 2012
    I posted a topic a while ago about having problems with my AA g23 Gen4 conversion slide. I could not get the slide lock mechanism to function correctly and I had to force the slide to lock up which was causing the slide to be pushed back to far to the rear and sitting about a 1/8 inch back to far from being correctly lined up with the frame.

    I sent pictures to AA and they said send the slide in for they can have a look. they tried the slide on three frames sent me pics and it lined up on all three fine.

    ArcAngel pointed out to check the slide lock mechanism and I did when I got the kit back. I had it it back wards :upeyes:. I switched the lock around the way it should be and now I cant even get my frame to lock the conversion slide into place at all! The factory slide still locks up fine. The only way I can even get the frame to start locking into place is if I have the slide lock inback wardss.
    I'm
    m very confused here on whats going on. Should I just buy a new slide lock mechanism and hope that takes care of the problem? Any thing else to look at?
     
  2. ken grant

    ken grant

    1,806
    233
    Apr 3, 2004
    middle ga.
    install the slidelock the proper way, install AA Kit and then put the end of the barrel against something and push.

    I bet it will work then.

    I have 5 AA Kits and only one of them acts this way. It is the G30 Conversion and I treat it as above and it locks in place.

    If I don't push in on the barrel, the slide lock doesn't catch as it should.
     


  3. theflatlander

    theflatlander

    88
    0
    Apr 19, 2012
    tried this with no luck. I think a new slide lock is in order. don't know what else to do. the only way I can get it work is with the slide lock turned around and then it still only partially locks
     
    Last edited: Nov 9, 2012