Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Forum at

Why should YOU join our forums?

  • Reason #1
  • Reason #2
  • Reason #3

Site Description

Problems installing programs onto a networked computer

Discussion in 'Tech Talk' started by Drjones, Jul 14, 2010.

  1. Hey guys.

    I'm having issues installing programs onto computers for a network I'm helping manage. There is a server, domain, Win Server 2003.

    The computers are connected to the domain and are brand-new Dells running Windows 7 Professional.

    Issue I'm having has been with Adobe Reader - just the basic, free reader - and now installing an HP Printer via USB. I think Quickbooks might also be giving the same user the same error:

    Both Adobe & the HP software are giving the same basic error which is that they can't find "My Documents" or that the "My Documents folder path contains an invalid character."

    The reason for this message is correct - the "My Documents" folder on all of these computers actually resides on the server - something like \\server\users\janedoe

    So how do I work around this and get the programs to install?

    I got a temporary workaround the Adobe issue by simply installing Foxit reader, but need to know how to fix this for the HP issue - we need to install the HP software so that the user can scan. It seems that Quickbooks is throwing the same error.

    I'd also like to know how to avoid this in general in the future.

  2. Pierre!

    Pierre! NRA Life Member

    Jun 20, 2003
    Lovin Sparks Nv!
    Gee... This is really hard to say without knowing what the Group Policies and Domain Security setup are...

    My Documents - It's been redirected? I have had issues with that in the past, and prefer to setup a task like Robocopy for evening copy of files to a particular folder on the server. Having a space in the name never helps the situation much either...

    You should check out the Group Policies and Domain Security to assure that this isn't what's clobbering you...

  3. Some software installers just don't work properly with network path names or with path names that are too long.

    Copy the installer file(s) to a folder on the local hard drive, that's the only solution I can think of.
  4. Could I create another user account, NOT hook it up to the domain, and try installing the programs in that account?

  5. I kinda like it, and here's a perfect example: One of the employees in this co. just had his laptop stolen. ALL company files are kept on the server, therefore there's not too much for us to worry about. From a security standpoint, it makes sense to me to have my docs map to the server. (Also makes migrating to new systems much, much quicker.)

    Again, the issue is that the program itself (HP printer software, Adobe Reader, etc) are freaking out when they see "My Documents = \\server\users\drjones" instead of "My documents = c:\users\drjones."

    I don't really see how the Group Policies / Domain Security would affect that.... :dunno:
  6. Pierre!

    Pierre! NRA Life Member

    Jun 20, 2003
    Lovin Sparks Nv!
    Glad to hear it works! I don't understand how he used it out of the office, but I assume VPN...

    Yah, I understand - and without reviewing the existing GP's it's really hard to say :whistling: You have computer and user settings in the GP that can affect software installation... but that isn't the point.

    This is a really good question that I didn't really get the answer to:
    This was all working just find and dandy with some other workstations in place, then the Win7 systems arrived? or this changed all of a sudden after the Win7 systems were working fine for a while?

    Also - are the GP policies for Server 2003 AD - GPMC SP1?, or updated from the Win7 systems? If you have RSAT for Win7 on a system and edit GP's from that system I believe it will update your templates. You may not see the actual full GP settings when you use the GPMC SP1 due to Server 2003 AD not being capable of showing these to you due to the GPMC SP1 not being up to the Win7 RSAT versions...

    Vista and Windows 7 did change alot regarding GP's. Add Server 2008 and there are some really wild things you can do... but it can be difficult to work old AD into Win7/Vista at times.

    Then, there is the "blocking" mode - Files on a server may appear to be in a different "zone" than the workstation is in, so there is a literal 'block' button on the file properties - do the Rt Click, Properties on one of the installation files - you might see "Unblock" down where the attributes are... click the Unblock and it might just solve your issue too...

    So let us know about the one question above about "it's been working and changed" or "new workstations came in and now it's Horked Up"... and also has the RSAT been installed to a Win7 and used to edit GPs'...

    Then check for the 'Blocked' condition...

    And we can go from there! :supergrin:
    Last edited: Jul 14, 2010
  7. We bought the new Win7 systems because the company is long overdue for upgrades (most systems are P4, 512MB RAM). I was in the process of getting them all set for first use when I ran into this issue with Adobe, Quickbooks and the HP Print/Scan software & drivers. So no, it's not as if they were working OK and suddenly stopped.

    I just emailed one of the users to ask if they had any issues installing programs on their old systems or not, so that could help narrow down the source of the problem.

    I will also give the "unblock" thing a try, as well as changing the My Docs path in the registry, and then changing it back when done.

    We haven't used RSAT for Win7.
  8. Pierre!

    Pierre! NRA Life Member

    Jun 20, 2003
    Lovin Sparks Nv!
    The other thought that I had this AM - What about the system's LOCAL policy??? Perhaps there is a conflict in there?

    It's been 9 months since I have been working domains - Been in and out of them since Oct 09, and haven't really gotten to work Win7 into a domain yet.

    I will have to lab it up, and see what's up. Something like what you are going through may end up in my lap one day... :wow: Better know something about it before it lands in my lap.

    Let me know what you find with the Block/Unblock issue. I am dealing with it on my Windows Home Server since the re-install last week.

  9. So here is what worked:

    1. Login as user
    2. Load Regedit
    3. Browse to HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    4. Make a note of current path for 'Personal'
    5. Change path to c:\documents and users\username\My Documents.
    6. Install program again.

    HOWEVER, every time the user logs onto the network, the "My Documents" gets remapped to the server, which is great & how I'd prefer it, but it is causing issues still - when quickbooks did its auto-update, it threw the same error about "My Documents contains an invalid character"

    I obviously can't troubleshoot this remotely while the user is in the office, since she is logged onto the network, and I really don't want to have to drive out there every time. I guess it could wait until the user takes their laptop home, though...

    Any further thoughts or ideas?
  10. Pierre!

    Pierre! NRA Life Member

    Jun 20, 2003
    Lovin Sparks Nv!
    So what is remapping My Docs when you are performing a regedit?

    Is it an old group policy? I may not be compatible with Win7 if it was done to address WinXP.

    I'll keep looking around when I get a minute... I am quite curios to find out what's hanging this up. You would think that the evolution of Win7 would almost dictate that the relocation of MyDocuments would be needed.

    You tried moving it the old fashioned way - GoTo:
    LocalDisk / Users / User Name / - Right Click MyDocuments/ select Properties / select Location / Enter Net Share Path desired or use Find Target / MOVE / Apply, and OK your way out...

    Any of that help?
    Last edited: Jul 16, 2010