close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

openBSD firewall question

Discussion in 'Tech Talk' started by David_G17, Nov 16, 2005.

  1. David_G17

    David_G17 /\/\/\/\/\/\/\/

    2,046
    0
    Oct 7, 2002
    I installed openBSD 3.8 on a spare computer and intend to setup a webserver on it.

    I noticed iptables isn't installed, but I'm running into problems that seem to point to a local firewall installed.

    What firewall software comes with openBSD?

    And how can I disable all filtering to test out my setup?
     
  2. David_G17

    David_G17 /\/\/\/\/\/\/\/

    2,046
    0
    Oct 7, 2002

  3. IDtheTarget

    IDtheTarget

    47
    0
    Oct 10, 2005
    I can't help with BSD, but if you want to give linux a try, I'm your guy. :) We use RedHat here at work, so the distro I use for training is CentOS. They download RedHat's source code, remove the trademark stuff, and re-compile. (Yes, RedHat allows this. :) )

    Sorry I couldn't help, but if you decide to switch, let me know.
     
  4. David_G17

    David_G17 /\/\/\/\/\/\/\/

    2,046
    0
    Oct 7, 2002
    disregard my former post, still having problems.

    pf wasn't enabled.

    here is my setup:

    Modem (192.168.1.1) -> Server (192.168.1.15)

    from within the same network, I can type in http://192.168.15:8080 and get to the server.

    but I can't type http://{public static ip}:8080 to get to it.

    My ISP blocks port 80, but I have run an online port scanner which tells my port 8080 is open.

    any suggestions?
     
  5. David_G17

    David_G17 /\/\/\/\/\/\/\/

    2,046
    0
    Oct 7, 2002
    we've got Red Hat Enterprise Edition, but we're moving to Debian where i work :( I like fedora core, and if I can't get this straightened out, I may have to install FC.
     
  6. thonl

    thonl Millennium Member

    199
    0
    Feb 7, 1999
    Great White North
    192.168.1.1 has to have some sort of port forwarding feature in order to allow outside access. You have to be able to tell it to forward :8080 requests to your inside machine, otherwise it is just trying to hit :8080 on the modem itself.
     
  7. David_G17

    David_G17 /\/\/\/\/\/\/\/

    2,046
    0
    Oct 7, 2002
    oops, I left that out of my description. The modem is set up to forward 8080 TCP requests to 192.168.1.15

    eta: actually, now that you mention it, I was playing with it earlier, and it may have two rules: one to forward 8080 traffic to 192.168.1.15 and one to forward 8080 traffic to 192.168.1.3 - I'm sure that could cause a conflict.

    edited again: well, still having same problem.