close

Privacy guaranteed - Your email is not shared with anyone.

New(to me) USP.45 prob?

Discussion in 'Heckler & Koch Forum' started by twoscoops, Mar 19, 2010.

  1. twoscoops

    twoscoops

    Joined:
    Feb 9, 2007
    Messages:
    112
    Likes Received:
    0
    Location:
    NC mountains
    I just picked up a traded in USP .45 and shot it for the first time yesterday and noticed that the slide doesnt lock back on an empty mag. I was wondering if this is common, mag, or something else. Gun shot great and I liked it alot. Thanks for any info.
    Chris
     
  2. H&K 4 LIFE

    H&K 4 LIFE Leonum A Ignis

    Joined:
    Jan 27, 2009
    Messages:
    3,381
    Likes Received:
    2
    Location:
    CT

  3. twoscoops

    twoscoops

    Joined:
    Feb 9, 2007
    Messages:
    112
    Likes Received:
    0
    Location:
    NC mountains
    Came with 3 and does it on all, 99% of the time. Ill check into the mag springs as that was something I was going to do anyway.
    Thanks,
    Chris
    ps. thanks for the link
     
    Last edited: Mar 19, 2010
  4. joe_jitsu

    joe_jitsu

    Joined:
    Apr 27, 2008
    Messages:
    26
    Likes Received:
    0
    Location:
    central TX
    As stated above, mag springs are one likely culprit. Also check the follower and slide stop tab for excessive wear. Of course, it is possible to "ride" the slide stop lever accidentally while shooting.

    Do they lock back by hand on an empty mag?
     
  5. HK Dan

    HK Dan

    Joined:
    Mar 27, 2008
    Messages:
    1,402
    Likes Received:
    0
    Also? Your thumb might be riding the slide lock lever (holding it down).

    Get some Wolf springs anyway, they're cheap insurance.
     
  6. twoscoops

    twoscoops

    Joined:
    Feb 9, 2007
    Messages:
    112
    Likes Received:
    0
    Location:
    NC mountains
    Thanks for the replys and no, they dont lock by hand on an empty mag either.
     
  7. twoscoops

    twoscoops

    Joined:
    Feb 9, 2007
    Messages:
    112
    Likes Received:
    0
    Location:
    NC mountains
    It was the mag springs. Stretched them out by hand and works fine. New springs on the way!!!