Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Forum at

Why should YOU join our forums?

  • Reason #1
  • Reason #2
  • Reason #3

Site Description

networking = NOTworking - - HELP

Discussion in 'Tech Talk' started by N2DFire, Jul 8, 2004.

  1. N2DFire

    N2DFire Who Me ???

    Apr 29, 2003
    Ferrum, VA
    O.K. Guru's I'm stumped on this one. I am trying to configure a simple file sharing network between 2 Windows XP Pro computers for a friend of mine (something I've actually done a couple of times already).

    I have swapped everything out of the entire set-up except the computers themselves and I can't figure this out.

    I will attempt to describe what's happening as best as possible.

    Computer R = IP = x.x.x.100
    Computer O = IP = x.x.x.101
    Test Laptop(LT) = x.x.x.102

    Router is Linksys BEFW11S4 (however I put this router on my home network and it functioned perfectly so I do not think it is the culprit) there is NO WAN / Internet connection on this network (future use) and the wireless is disabled (future use)

    All cables are Belkin off the rack (not home made) and have been swapped around and are assumed good.

    Here goes:
    All computers that connect to the router are using DHCP and all are assigned an IP address.
    Note - all pinging was done by IP address. Name resolution on this network fails - however when used on my home network - names resolved fine.

    From Computer O I can ping Computer R and LT but can NOT ping itself
    From LT I can ping Computer R and itself but NOT Computer O
    From Computer R I can ping LT & Itself but NOT Computer O

    (I know it gets screwier - I had to draw myself a picture just to get this far ;g )

    Computer O & R are "off the shelf" Dell systems running identical hardware & software (including Norton AV) and both network cards are configured alike.

    The only difference I can find is computer O is also configured with a dial-up internet connection with Windows firewall enabled. I tried disabling the firewall to see if that was affecting things but it did not help.

    I also tried to remove & re-detect the network card in hopes of killing any hidden setting that may have been skewed.

    This is for my friends small business and she really can't afford to call in the "big boys" to come set this up for her but I'm beyond the scope of my intelligence - any help you folks can offer would be greatly appreciated.

    Also - speed is of the essence - computer O is supposed to play the role of "server" to her Point of Sale software and until this network issue is resolved she cannot start entering her inventory and that is on the verge of delaying the opening date for her store.

    Thank you in advance for any assistance you can provide.
  2. Z3N


    Nov 13, 2003
    off hand, it sounds like the "O" computer is setup to block incoming ICMP (ping) traffic. If all you are doing is setting up a 2 computer share situation, forget about pinging for a moment. Can you see the shares from any of the computers?

    If that still does not work, uninstall "TCP/IP" and reinstall it.

    If you are not going to use the internet on any of these systems, get rid of that router as well. Put a good, cheap 10/100 hub in its place (just my suggestion).

  3. HerrGlock

    HerrGlock Scouts Out CLM

    Dec 28, 2000
    Eliminate all firewalls. Do not put them back up until you start locking it back down.

    Computer O is having a problem. Are you sure of its IP? If it's not able to ping itself, that's problems. Try pinging localhost on computer O and see if that works.

    Take out DHCP and give each of them static IPs of the same IP you believe them to be.

    DNS doesn't work? What are you using as the DNS server?
  4. HerrGlock

    HerrGlock Scouts Out CLM

    Dec 28, 2000
    I'd agree with this. I'd say switch instead of hub, but agree with the idea.

  5. gudel


    Jun 1, 2001
    even with XP firewall on, i can ping myself.

    do ipconfig /all on your computer O, and show me what you got.
    also, it helps to enable File and Printer Sharing on your O computer :)
  6. chevrofreak

    chevrofreak Senior Member

    Dec 27, 2001
    Billings, Montana
    go to Network and Dial-up Connections

    right click the network connection, and click properties

    click Internet Protocol(TCP/IP)

    Click properties

    click advanced

    click options

    click TCP/IP filtering

    click properties

    Is TCP/IP filtering enabled?

    Back where you clicked TCP/IP Filtering, click IP security, then properties

    Is "Do not use IPSEC" checked?
  7. N2DFire

    N2DFire Who Me ???

    Apr 29, 2003
    Ferrum, VA
    O.K. First - thanks for the replies, given me a couple of good things to go on.

    Right now I don't have acces to these systems (I'm at work) but I'll respond to what I can & I'll call her and get her to check the rest when she can.

    I did not attempt to set up the shares since I could not confirm connectivity via pinging but I will try this also.

    Tried that - from the Connection properties - the uninstall button is disabled when "Internet Protocol (TCP/IP)" is selected.

    I did remove the card via hardware manager & let Plug & Play re-detect it. Still has same behavior.

    The internet is a future requirment once these are moved to the new store location. It's just not available now - I just said it was a Future item to (possibly) eliminate some options.

    The only firewall that is in place (that I know of / have found thus far) was the firewall on the Dial-up connection which I did remove w/ no change in behavior. I will do further investigation.

    Agreed - at this point I am 99.9% sure that the issue lies somewhere on Computer O - I just can't seem to get my brain around what it is.

    ping localhost resolves (if I remember correctly)

    I did the static IP route on Day 1 (when I thought this was a router problem) and that did not work either.

    DNS dosen't work with THESE systems. When I placed this router on my home network (in place of my D-link router), everything worked fine including DNS. The router is configured exactly the same here as it was in my home so I can't see where the router is to blame.

    The Router is (or should be) the DNS server as far as I know.

    I know file & printer sharing was installed on both network cards but if there is more to enabling it - I'll have to go back and check. On my other networks I simply make duplicate accounts on both machines and they are both admin (I know - bad idea) so I use the default admin shares for what little I do.

    I can't do the IPCONFIG/ALL for you as I have no access to the PC right now.

    I did not check that last night - I will call her today and get her to check this.

    O.K. - belive it or not - you lost me. If that is supposed to be a second entry on the options page under TCP/IP filtering then it's not even there. I just checked the settings on my laptop (which I matched to both computers last night) and it's not on mine.

    Again - thanks everyone who has offered suggestions thus far. Any question that I have not answered yet - I will try to do so tonight.
  8. Z3N


    Nov 13, 2003
    To try to reset the TCP/IP stack, give this a shot:
    MS Knowledgebase Article

    I wouldn't worry about name resolution. If the ip addresses work, let them handle traffic flow. It will cut down on the translation that ever item on the network will have to do.

    Some systems don't have the IPSEC option (mine at work does not). I'm not sure what offers that option...

    As I said before, it sounds like something on the "O" machine is blocking the ICMP inbound requests. Now, if you have disabled the firewall the other possible culprits could be the IP Filtering or a 3rd party package (however, you did not state if there was loaded so I am assuming that there is not).

    Also, look to see if the ICS service is running (Control Panel > Admin Tools > Services). If it is, stop it and change the start up option to keep it from cranking back up after a restart.

    I hope something in this thread helps... I know how annoying these network problems can be.
  9. N2DFire

    N2DFire Who Me ???

    Apr 29, 2003
    Ferrum, VA
    I GOT IT !!!!

    (And boy do I feel so stupid!!)

    It ended up being Norton Firewall of all things. Both systems were running it but they were configured differently. Once I finally found it & fixed it all is now right with the world.

    A hearty thank you to one and all who contributed ideas to this problem.

    *Edited for grammer*
  10. SamBuca


    Aug 9, 2002
    Carlisle, PA
    Step 1 after installing Norton Internet Security + AV is to completely disable the "internet security" portion, set it to manual loading, and disable the systray icon ;f

    <rant_at_norton gratuity="Thank you for letting me rant in your thread">
    Every single problem ever discussed that revolves around not being able to connect has been traced to Norton. Every single one. I'm tempted to print out a "Why this setup is stupid" paper and hand it out to all my customers....firewalling a machine that's already behind a router is pointless for a home network.