close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

My New 70-300IS Is Going Back...

Discussion in 'Through-the-Lens Club' started by DeadMansLife, Mar 6, 2008.

  1. DeadMansLife

    DeadMansLife Senior Member

    916
    1
    May 7, 2000
    Carlisle, PA
    I waited for almost a year for this lens, I got it and now I have to send it back!!!:frown:

    There is an ever so small mark on the front element. Just enough to show in pics.

    I had plans for this lens for this weekend, I guess I'll have to reschedule.
     
  2. hwyhobo

    hwyhobo

    1,426
    0
    Jun 3, 2003
    Silicon Valley
    Sorry to hear that. Alas, it is yet another confirmation of spotty recent Canon QC.
     


  3. nipperwolf

    nipperwolf

    3,070
    27
    Oct 3, 2002
    That bites.

    Can you rent one for the shoot?
     
  4. DeadMansLife

    DeadMansLife Senior Member

    916
    1
    May 7, 2000
    Carlisle, PA
    It was for a personal shoot that can be rescheduled without much hassle. I just hate to make plans then cancel due to faulty NEW equipment.

    Oh well, if it wasn't this it would be the weather.
     
  5. MrsKitty

    MrsKitty

    18,802
    31
    Mar 23, 2003
    >^..^<
    Ow. That bites. :sad:

    Can you post a pic? I am curious to see how bad it is/what it is.

    Be careful. When Nip suggested that I rent a lens a few weeks ago, I bought it instead. :rofl:
     
  6. DeadMansLife

    DeadMansLife Senior Member

    916
    1
    May 7, 2000
    Carlisle, PA
    I couldn't get a pic of the element damage, it was so small it could barely be seen. It does show on images tho. I thought it was dust on the sensor but it was not there when I put the 18-55 back on the camera. I also noticed it in different locations on different images. The front element rotates when focusing with this lens.

    here is a 100% crop of the bad spot:
    View attachment 144469

    I know, it's small and easy to fix but it is was not ordered with the lens:upeyes:

    No need to rent a lens for the weekend, the weather is not looking very good for the next few days. I'm gonna cancel my plans anyway.

    I used the 70-300 to get the pic for my avatar. I cropped out the bad spot.
     
  7. nipperwolf

    nipperwolf

    3,070
    27
    Oct 3, 2002
    I'm getting ready to send my D200 in for a focus system check, I would like to suggest that you rent a D300 for me. :wavey:
     
  8. MrsKitty

    MrsKitty

    18,802
    31
    Mar 23, 2003
    >^..^<
    Exactly.

    Damn, that sucks. :sad:
     
  9. MrsKitty

    MrsKitty

    18,802
    31
    Mar 23, 2003
    >^..^<
    Ha! :tongueout:
     
  10. DeadMansLife

    DeadMansLife Senior Member

    916
    1
    May 7, 2000
    Carlisle, PA