More Ubuntu challenges: help a newb get 12.04 on wife's Dell Inspiron

Discussion in 'Tech Talk' started by Jim1970, Nov 11, 2012.


  1. Jim1970

    Jim1970 Learnin'

    492
    1
    Hello,

    I have been learning about and enjoying Ubuntu on my Toshiba Satellite, with considerable help from the good folks here at GT. My wife has watched my progress, and she has asked me to install Ubuntu on her Dell Inspiron 1501. I installed it from the CD and set it up to dual-boot, as she wants to try before she commits.

    No trouble - install went without a hitch, until near the end. Then I received a message about being offline. I tried to connect via wireless connection (do not have a wired option at home) and received message indicating there were no drivers present. I did some googling and researching, and what I understand is that there is a known bug with Broadcom hardware in Dell machines. I found all kinds of text that I could add into a terminal, but I don't even know what a terminal is! I'm an old DOS guy, so I am figuring terminal simply a command prompt. Still, I would like some help before I go any further!

    Please help! What's the fix here?

    Thanks!

    Jim
     

    Wanna kill these ads? We can help!
  2. Loading...

    Similar Threads Forum Date
    More ubuntu questions Tech Talk Mar 10, 2011
    Ubuntu Was More Popular Than Britney Spears Tech Talk Dec 28, 2009
    More Ubuntu questions Tech Talk May 17, 2008
    How much more velocity with G23 barrel in G27? The Sub Club Friday at 1:17 PM
    Lott: More Americans carry guns - and feel safer Gun-Control Issues Wednesday at 11:25 PM

  3. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    First, I'm assuming this is an internal wireless device(if it's USB, it's a bit different).
    Open up a terminal
    type this "lspci" (no quotes, that's a lowercase L).. and hit enter.

    That should spit out some info about devices that are on the PCI bus (of which your internal wireless device is one)... Go through the list, and find your wireless device... Since it's a Dell, it's almost 100% a Broadcom... The line will look something like this...

    03:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

    The key to figuring this out, will be the number after "BCM"..

    Post it, and I should be able to help you get it going.
     

    #2 IndyGunFreak, Nov 11, 2012
    Last edited: Nov 11, 2012
  4. Jim1970

    Jim1970 Learnin'

    492
    1
    The code after BCM is 4311.

    What's next?
     
  5. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    This may look kinda long, but I tried to make sure this was fairly detailed as I know your linux experience is... limited :)

    OK, first... you're going to need:

    1. Your Installation CD

    2. A machine with a working internet connection (which you obviously have now)

    3. Something to transfer a file to your Ubuntu machine, from the machine that has Internet access (thumb drive, burn another CD, we'll assume a thumb drive).

    First...

    Make sure Ubuntu is booted and you're logged in.
    Insert the installation CD
    On the left (where all the program icons are), you should see the "CD" pop up.
    Right click the CD and choose Open
    You should get a window showing various folders that are on the CD (boot, casper, dists, pool, etc..)
    Navigate to /pool/main/b/b43-fwcutter
    Inside the b43-fwcutter folder, is a file called b43-fwcutter_xxx.deb Double click that .deb file and Ubuntu Software center should open up.. Just click install, and let it install.

    On the machine with a working Internet connection, download this file
    http://mirror2.openwrt.org/sources/broadcom-wl-5.10.56.27.3_mipsel.tar.bz2

    Also create a text file (I'm assuming the machine with a working connection is a windows machine, so .txt will work fine)

    Copy and paste these 2 lines into the txt file:
    Code:
    tar xfvj broadcom-wl-4.150.10.5.tar.bz2
    Code:
    sudo b43-fwcutter -w /lib/firmware broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o
    Save the text file

    Now move the .tar.bz2 file and the .txt file to the Ubuntu Machine

    First, put the .tar.bz2 file, INSIDE YOUR HOME DIRECTORY. Don't put it in the Downloads folder, or Documents folder... just drop it in your home directory.

    Open up a terminal
    Open up that .txt file.

    Copy/paste the first line into the terminal and hit enter. When it finishes, copy/paste the 2nd line into the terminal, and hit enter. You'll be prompted to enter your username password. Type your password and hit enter (note, you won't see any *** or --- so just type your password and hit enter)

    Let that finish.

    When it's done, click the "Dash Home" button, and do a search for "Additional Drivers".. and Open the Additional Drivers utility.

    You should see an option there that says "b43". Highlight it and click Activate (you'll probably get a message you need to restart)

    Restart your machine.

    When you log in, give it a second, then you should be able to click the Networking applet, and you should your wireless network. Simply enter your credentials and connect.

    IGF
     
    #4 IndyGunFreak, Nov 11, 2012
    Last edited: Nov 11, 2012
  6. Jim1970

    Jim1970 Learnin'

    492
    1
    IGF,

    Holy crap! That's a lot to do! I vow to move slowly and pay attention.

    Only one issue I see: the machine with the internet connection is running exclusively Ubuntu. Can I copy and paste a .txt file in Ubuntu?

    Gonna gobble some lunch, then I will launch into this. Please stand by!

    Thanks for your help and wisdom.

    Jim
     
  7. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    If it's running Ubuntu... just right click, choose "create new new document" then "create empty document"... That will more or less create a text file for you.

    It's really not near as "much" as it looks. I probably could have broke that down into 4-5 steps for someone that had a clear understanding of Linux.
     
    #6 IndyGunFreak, Nov 11, 2012
    Last edited: Nov 11, 2012
  8. Jim1970

    Jim1970 Learnin'

    492
    1
    IGF,

    Got to the file on the cd. Double clicked it, but the install button is greyed out and not selectable.

    ??
     
  9. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    That's weird.... Usually only does that when you've started software center, and you declined to be root. Did you enter your password when software center started? Close Software center, then double click the .deb file again, and if it asks you to enter your password, enter it.
     
  10. Jim1970

    Jim1970 Learnin'

    492
    1
    Okay, software center was open. I closed it, then went back to the file and double clicked it. Same as before.

    Should I pull the CD, then reboot and try again?
     
  11. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    Yeah, go ahead and try that...
     
  12. Jim1970

    Jim1970 Learnin'

    492
    1
    No difference - button is grayed out.
     
  13. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    OK.

    Drag/Drop the .deb file to your desktop.

    Open a terminal

    Type this

    sudo dpkg -i (then hit the space bar one time... make sure there's a space after "dpkg" also)

    After that, drag/drop the .deb file into the terminal...

    You should see the path and file added to the end of what you just typed (should look something like sudo dpkg -i "/home/username/Desktop/somefile.deb")

    Hit enter, and then enter your password. It should start installing, if it doesn't install and you get an error, let me know the error.
     
  14. Jim1970

    Jim1970 Learnin'

    492
    1
    Okay, did the drag and drop to the desktop, then opened terminal and typed the text, then did the drag and drop; this took me to the same screen I saw before, and that damn button is STILL all gray - selecting "install" is not an option!

    Ugh.
     
  15. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    You're not listening again...

    Read what I said... Open a terminal and go from there.. I'm not sure why you're having that problem, we'll have to figure that out later.

    If you ran that from the terminal, you should have seen it installing afte ryou entered your password. If it didn't install, you should have gotten an error as to why...

    The funny thing about htis... if you have an ethernet cable and could hook the laptop up to a router for about 2min... this would be done..lol.

    IGF
     
    #14 IndyGunFreak, Nov 11, 2012
    Last edited: Nov 11, 2012
  16. Jim1970

    Jim1970 Learnin'

    492
    1
    Okay. Went back and read your previous email. Then went back and repeated the steps from that email.

    Opened a terminal; then typed 'sudo dpkg -i' with a space after the 'i.' Received an error that said,

    "dpkg error: -- install needs at least one package archive file argument." Underneath that, there were different extensions that could be used with dpkg commands - like "type dpkg -Dhelp for a list of dpgk debug flag values."

    It's got to be me. What am I doing wrong?

    Jim
     
  17. Jim1970

    Jim1970 Learnin'

    492
    1
    I can take it to work and plug in via ethernet cable - but that won't be until Wednesday. If it can be done today, that would be preferred. If it cannot, then it's not a huge deal.

    Thank you again for your help,

    Jim
     
  18. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    Yes, it's you..

    type sudo dpkg -i (make sure there's a space after -i and after dpkg)...

    Then Drag/drop the .deb file TO THE TERMINAL... this should complete a path in the terminal and you should get something like sudo dpkg -i '/home/username/Desktop/filename.deb' then just hit enter.

    IGF
     
  19. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    Well, hopefully it worked and you're continuing w/ the instructions.. :)
     
  20. Jim1970

    Jim1970 Learnin'

    492
    1
    IGF,

    I gave up! I did the drag and drop into the terminal screen, then hit enter. The next screen was the same install screen I'd already been to; and the button was still not an option.

    I will connect to my network via ethernet on Wednesday. Once I do that, what do I need to do?

    Thank you,

    Jim
     
  21. IndyGunFreak

    IndyGunFreak KO Windows

    24,649
    114
    Hmm, that doesn't make a lot of sense.. dpkg is a command line utility, and shouldn't open up the software center. I'm still confused why you can't install it from the cd... not sure whats going on there.

    Regardless, this should do it.

    Plug the laptop into the internet connection
    sudo apt-get update
    sudo apt-get install firmware-b43-installer

    Let it finish, then go to Additional Drivers, and activate the b43 driver and restart.

    I believe that should do it

    I'm not sure why you're having problems w/ the instructions I put above, I went through them 3x on my broadcom machine (on a live cd, w/o an internet connection) and it worked just fine.

    IGF
     

Share This Page

Duty Gear at CopsPlus