close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

More fun... Runtime Errors again...

Discussion in 'Tech Talk' started by Obi Wan, May 18, 2009.

  1. Obi Wan

    Obi Wan

    2,113
    15
    Oct 13, 2007
    'Round the bend...
    On our HP Pavilion z4230 laptop - whenever my wife goes to run CCleaner, she gets a Runtime Error right when it hits 43% completion. As soon as you hit "OK", it shuts the program down.

    This just started happening the other day. I had her download and install a copy of the v2.19 program, but that didn't help other than now the error stops it at 40% completion vs. 43%... :dunno:

    She's running XP Home, SP2, with the Firefox 3.0.10 browser.

    Yesterday's description details of the problem starts with:

    "The thread attempted to read from or write to a virtual address for which it does not have the appropriate address"

    CCleaner v2.18.878...


    I checked Virtual Memory settings and the minimum is set to 1437MB with the max set at the same (per prior tech advise here), due to the memory/runtime error problems we were having a few weeks ago. At that time we cleaned out about 6 MB of files to open up a total of about 11MB out of the 30MB on the HDD and the problems seemed to go away. Thought that would be enough...

    Any ideas?

    Thanks.
     
  2. MavsX

    MavsX The Dude Abides

    3,033
    0
    Jan 19, 2009
    Arlington, VA

  3. NGWT

    NGWT

    358
    0
    Jun 7, 2003
    FL
    Given your previous attempts at fixing this it is probably a hardware problem.

    If you go to Google and query on:

    ccleaner thread attempted to read from or write virtual address appropriate access

    You'll get some decent hits with some ideas. Try the one about going back to an earlier version too.

    If it still doesn't work, and it were me, I'd use the HP restore to get me back to a clean system. Then, first thing, install ccleaner and see if it works.
     
  4. ron59

    ron59 Bustin Caps

    6,927
    20
    Jan 3, 2009
    Smyrna, GA
    I've occasionally had problems with programs like this when the screen saver tries to come on.

    It sees that the computer is "idle" (ie, user hasn't touched mouse/keyboard in awhile) so it tries to come on and it then conflicts with the program trying to do work.

    I KNOW I had problem with Windows disk checker with this issue, I'd have to disable the screensaver (or boot to safe mode) when I tried to do that.

    Just a wild guess, but give that a shot?