Privacy guaranteed - Your email is not shared with anyone.

Is something broken or what?

Discussion in 'General Glocking' started by jhon, Feb 10, 2012.

  1. jhon


    Dec 1, 2010
    I have a G19 and have about 1000 rds thru it now. No problems of any type until now. I came back from the range yesterday and did my cleaning today. However when I went to put the gun back together, I was not able to get a full slide back.

    In other words, I was unable to pull the slide all the way back. It would only go aprox 1/2 of the way. I took it apart and tried to see if I got something in wrong or the spring/rod was not right. I was unable to see anything wrong.

    Once again, I took it apart and then reassembled it again and had the same results. What would be causing the blockage to keep from getting a full slide?

    Besides being a little frustrated, I didn't do anything different with the G19, then I have with my G26. They both disassemble and reassemble the same way.

    Any clues?

  2. DannyII


    Jul 25, 2011
    1. RSA not in the correct slot at he barrel end.

    2. Trigger not to the rear all the way.

  3. IMightBeWrong

    IMightBeWrong Straw Dog

    Feb 2, 2009
    Phoenix, AZ
    What Danny said, and also:

    Take a close look at any parts that could interfere with slide movement if damaged (ejector, trigger bar, parts of the trigger group) and see if they look dented or out of place. Did you do any disassembling aside from field stripping? If so, make sure you're putting the pistol back together properly. The order in which the pins are re-inserted actually does matter.

    Might not be too helpful since I've never seen the issue you're having, but it's what came to mind for me.
  4. Chrisdsm22


    Aug 31, 2011
    This same thing happened to me last night. Try feild stripping again and make sure your rsa is seated all the way down. I took it apart a couple of times trying to figure it out and it finally worked. Also try spinning the rsa around. Don't flip it just spin it. Weird I know but, it might help. Mine seemed to lock up more when i push on one side more than the other.
  5. voyager4520

    voyager4520 -----

    Apr 25, 2009
    SE Colorado
    What ammo were you shooting during the last range trip?

    Disassemble it again and take the barrel and guide rod out of the slide. Look at the inside of the slide where the top of the squared portion of the barrel chamber would rub against, you'll see a definite wear mark. Now put the barrel in the slide and push the barrel forward until the front of the squared portion of the barrel would line up with that wear mark.

    Did the barrel go approximately all the way to that wear mark? Or did it stop pretty short of that mark? If it stopped pretty short, the issue may be a bulged barrel caused by overpressure when the gun was fired.


    See the wear mark inside the slide between the two red lines:
    Last edited: Feb 11, 2012
  6. GaryC


    Apr 3, 2011
    I have seen this happen with Gen 4 G17s with the early RSAs in them. The metal sleeve between the inner and outer springs on the early ones could hang up on the outer spring front coils and prevent the slide from going all the way back.

    Check to see that spacer protrudes thru the front of the slide when you pull the slide back. If it doesn't, that is your problem.
    Last edited: Feb 11, 2012
  7. kodiakpb


    Jan 12, 2012
    That was my first thought