close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

Is Everyone having problems with GlockTalk?

Discussion in 'Tech Talk' started by LanceOregon, Jan 4, 2009.

  1. LanceOregon

    LanceOregon

    2,898
    0
    Jun 30, 2008
    I've recently begun to experience major problems in using the GlockTalk website. Pages on the site now load so very slow. In the last couple of days it has improved some, but is still taking 40 to 45 seconds to respond and load a page. Before that, I was getting delays as long as a minute and 40 seconds.

    Besides being so extremely slow, I am also often being kicked back out to the main GlockTalk men, instead of the requested page loading. This has happened when trying to click on one of the forums to enter it, when trying to open up a thread, and even sometimes when I try to post a message. Instead of any of those things happening, I just get kicked back out to the main GlockTalk menu.

    It is becoming so very frustrating. GlockTalk is close to beingt unusable for me currently.

    Any ideas what is going on?

    .
     

  2. RDW

    RDW BTDT

    2,500
    0
    Mar 12, 2003
    PRK
  3. Razrbk444

    Razrbk444 Sumthin' Witty Silver Member

    1,112
    31
    Jul 22, 2006
    NE Arkansas
  4. LanceOregon

    LanceOregon

    2,898
    0
    Jun 30, 2008
    Strange. Tonight is back to really being even worse. It is simply awful.

    I am probably going to have to give up on GlockTalk, unless I can figure this out. No problems at all until this past month. And I am having no problems of any kind on any other websites that I frequent, including many others that use vBulletin.

    I am using FireFox as my web browser, but that really should be a non-issue too.
     
  5. Dalton Wayne

    Dalton Wayne Epic mustache Millennium Member

    12,633
    7
    Apr 5, 1999
    Central Florida
    I use IE as my browser and never had a problem. :cool:
    Regards
    DW
     
  6. Razrbk444

    Razrbk444 Sumthin' Witty Silver Member

    1,112
    31
    Jul 22, 2006
    NE Arkansas
    I'm using Firefox and GT is smoking right along. Have you tried clearing your cache and history in FF?
     
  7. pesticidal

    pesticidal Eh? CLM

    11,814
    22
    Jun 5, 2002
    North Dakota
    I'm having no trouble. Occasionally, with Firefox, if I have too many tabs open, it slows up everything. I close out Firefox, kill the process, and all is well again.
     
  8. Free Radical

    Free Radical Miembro Antiguo CLM

    9,988
    0
    Sep 11, 2005
    Four Corners
    Occasionally I get what you are describing. I have no idea why. Tonight it's nice and fast. BTW, I'm using Firefox.
     
  9. Big Al 24

    Big Al 24

    1,244
    0
    Apr 23, 2008
    I would do all appropriate scans and defrags to make sure there isn't something else going on there that you aren't aware of.
     
  10. I just started with FF how do I do that??,,,when the time is needed
     
  11. IndyGunFreak

    IndyGunFreak

    25,941
    1,162
    Jan 26, 2001
    Indiana
    FF shouldn't be an issue.. However trying another browser (IE, Opera, whatever) if GT works well, then that will narrow the problem down to FF. Clearing the cache and browser history is where I would start.

    IGF