close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

Help Kimber Broke....

Discussion in '1911 Forums' started by Fifty Thousand, Feb 8, 2011.

  1. Fifty Thousand

    Fifty Thousand

    75
    0
    Mar 3, 2010
    Ok fjrst off. This is my first 1911. Kimber Pro Carry II. Bought brand new 2 weeks ago. So still never fired except factory test round. With a full mag, kimber, chip McCormick and Wilson Combat the gun jams. Now this only happens when theres 6 or more rounds in the mag. I cant for the life if me figure this ine out. Ive tried Corbon, speer gold dot and federal. Range ammo all with same results. The slide will nit close and the gun is not picking up a round. Please help.
     
  2. GeorgiaRedfish

    GeorgiaRedfish Senior Member

    3,819
    0
    Jun 29, 2010
    Right behind you...
    ooohh man hold on for this ride. This is one 1911 forum not to bash kimbers in.:rofl:

    UbtN- unverified before the Nick

    Oh and call kimber and let them deal with it. I've heard of them paying shipping both ways too.
     

    Last edited: Feb 8, 2011

  3. Fifty Thousand

    Fifty Thousand

    75
    0
    Mar 3, 2010
    I love the gun. I just want it fixed. Im not bashing anything. I am keeping this pistol as my first 1911
     
  4. Quack

    Quack Rent this space

    9,991
    9
    Jan 7, 2002
    NE Ohio
    check your extractor.

    are you limp wristing?

    could also be the recoil spring
     
    Last edited: Feb 8, 2011
  5. Fifty Thousand

    Fifty Thousand

    75
    0
    Mar 3, 2010
    Again still never fired. It wont pick up the first round in the mag to fire at all. I guess i will just call kimber. I would rather get it fixed locally though you know instead of shipping and being gone 6 wreks.
     
  6. Hokie1911

    Hokie1911 >

    9,712
    1
    Dec 26, 2003
    NE Ohio
    I thought Kimbers NEVER broke and that was an interweb rumor.

    :popcorn:

    OP - hope you get your PC running right. Hopefully Kimber doesn't give you the "call us back after 500 rounds" bit...
     
  7. Quack

    Quack Rent this space

    9,991
    9
    Jan 7, 2002
    NE Ohio
    How are you chambering the round?
     
  8. Fifty Thousand

    Fifty Thousand

    75
    0
    Mar 3, 2010
    When i first noticed this problem i had the slide locked back. Inserted mag and released slide. For it to only come forward a quarter inch or so and get stuck. Round was unmoved in magazine. Then i tried to manually jack one into the chamber and sane results.
     
  9. Rinspeed

    Rinspeed JAFO

    10,100
    629
    Feb 28, 2001
    NY
  10. samuse

    samuse

    5,375
    21
    Jul 30, 2008
    South TX
    Sounds like the round is hitting the feedramp or getting bound up in the chamber?

    Could be a tight extractor, tight chamber, weak recoil spring, improper angle on the feedramp.

    I'd try to get Kimber to fix it. If they didn't get right after a few times, dicth it...
     
  11. Quack

    Quack Rent this space

    9,991
    9
    Jan 7, 2002
    NE Ohio
    How did you release the slide?
    Have you tried fmj ammo?
     
  12. Z28ricer

    Z28ricer

    885
    0
    Aug 4, 2005
    Tampa, FL
    Try just loading to 6 on each mag and at least attempt the 500rd break in ?
     
  13. Z28ricer

    Z28ricer

    885
    0
    Aug 4, 2005
    Tampa, FL
    Combine it being tight still, with a good bit of spring pressure from the mags loaded all the way, and its probably giving it a little trouble, especially when you're trying it with HP's
     
  14. Nickpisp

    Nickpisp

    1,260
    0
    Oct 12, 2010
    Oklahoma
    Lube it up really well and get a Wolff recoil spring for 4" Kimbers.
     
  15. GeorgiaRedfish

    GeorgiaRedfish Senior Member

    3,819
    0
    Jun 29, 2010
    Right behind you...
    sounded all kind of dirty
     
  16. Hokie1911

    Hokie1911 >

    9,712
    1
    Dec 26, 2003
    NE Ohio
    This reminds me of that thread a while back with that dude that sold his Glock, bought a RIA and was determined to break it in with HPs "just because", jacked it all up and was confused as to why it wasn't working, sold it, and went and bought his Glock back. :rofl:
     
  17. gearys 5600

    gearys 5600

    18
    0
    Jan 31, 2010


    I had problems with an ultra cdp, I got the "call us back after 500 rounds" After 800 rounds and still with a gun I couldnt trust. I sold it. Then had problems with my 4" pro kimber. I sold all 5 of my kimbers and bought two new wilsons.
     
  18. 20South

    20South

    2,256
    8
    Nov 18, 2002
    East of CBUS
    Has to be NC ALE :tongueout:
     
  19. glock2740

    glock2740 Gun lover.

    18,888
    13
    Jun 19, 2008
    NW Ark.
    I've never had to run anymore than 250-300 rounds through my Kimbers to make them 100% with HP's. Those first 250-300 rounds are factory FMJ's using Wilson or Tripp Cobra mags, running the gun dripping wet after racking the slide 100-200 times before ever firing a round. Seems funny how I've never had any issues with 9 different Kimbers using this same routine, as well as all my buddies who've bought Kimbers and followed that same break-in routine. I guess we just got the only "good" Kimbers. :dunno:As for the OP, I'd call Kimber and tell them what's happening. If they ask, then just tell them that you ran 500 rounds through it. I personally don't think ANY gun should HAVE to have 500 rounds ran through it before it's deemed "broken in". I run 250-300 rounds of factory FMJ's through ANY of my guns, before I start running HP's through them. Then after 50-100 rounds of what I plan on carrying in it for SD, without any issues, I personally deem the gun ready for SD use, whether it's for CC or HD. Works for me anyway.
     
  20. gearys 5600

    gearys 5600

    18
    0
    Jan 31, 2010

    LOL..:rofl: