Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Forum at

Why should YOU join our forums?

  • Reason #1
  • Reason #2
  • Reason #3

Site Description

Help - keep getting kicked of the Internet.

Discussion in 'Tech Talk' started by RussD, May 31, 2007.

  1. RussD

    RussD Millennium Member

    Sep 28, 1999
    Tampa, Florida, USA
    I have broadband cable through Roadrunner. I have Windows XP. I'm using the latest verson of Explorer and Outlook (for email).

    Starting a couple weeks ago, I can only stay connected for about 1 to 1½ hours before I have to restart my computer. I can't figure out what is happening.

    This is how it goes. I get on the computer. I'm cruising the Internet, newsgroups, email. All works fine. After about 1 - 1.5 hours, it just stops.

    I enter run command and pull up ipconfig and try to release and then renew my ip address. I get the message, "Unable to complete the command. The RPC server is unavailable."

    If I reboot my computer, all is fine and I can get back on the Internet.

    I've searched the Internet for RPC server errors, but everything I find has to do with Windows 2000, not XP.

    Any ideas what's going on?

    I'm thinking I'll have to break down and call my ISP, but I hate to do that because most of the time I know more about computers than one of the guys I end up talking to.
  2. srhoades


    Jul 14, 2000
    Try unplugging your router/modem and leave it off for a few minutes and then power it back up. If you do have a router check for a firmware upgrade.

  3. HAVOC

    HAVOC Remember Millennium Member CLM

    Jun 20, 1999
    Location: Location:
    Are you SURE it says RPC server and not DHCP server?

    How is the PC connected? cat5? USB? Wireless?
  4. Russ,

    I just had the same problem with my DSL,

    called my provider and fixed it in about ten seconds...

    Do you have your cable going through a surge-protector????

    if you do, unplug it from the surge protector and go straight into your modem.....

    DSL tech says they have tons of calls for this problem and the surge protector causes the signal to be shut off at times..
  5. RussD

    RussD Millennium Member

    Sep 28, 1999
    Tampa, Florida, USA
    Connection is through an ethernet card/cat 5 cable to the cable modem, which is connected to my cable. No, my computer is connected to a surge protector, but the cable modem itself is just plugged into the wall.

    I've tried "rebooting" the cable modem by unplugging it. That didn't work.

    Yes, it definitely says RPC server. I have changed nothing on my computer for quite some time, and this just started happening a couple weeks ago. The only thing that seems to fix it is rebooting my computer.

    I've scanned my computer for viruses and don't have any, so that doesn't seem to be it.
  6. RussD

    RussD Millennium Member

    Sep 28, 1999
    Tampa, Florida, USA
    Okay, it happened again tonight. I got on the Internet about 7:30 PM. At 9:15 PM, I was kicked off.

    I tried ipconfig/release & ipconfig/renew and this is the exact message I got:

    "An error occurred while renewing interface Local Area Connection: The RPC server is unavailable."

    I tried pinging a server (glocktalk, roadrunner, any website) and after some time it says it can not find the server.

    So for some reason, my connection is just stopping and as I said, I have to reboot the computer to get back on. Any ideas???
  7. srhoades


    Jul 14, 2000
    I googled around a bit and see that a virus or worm can cause it. Are your definitions up to date and have you checked for spyware?

    The other thing to check is to go to control panel>administrative tools>services. Restart the DHCP and RPC server services and then try to renew your IP. (if any of them are set to manual or disabled make then automatic.)
  8. doktarZues

    doktarZues I'm anti-anti

    Nov 11, 2003
    Brevard County, FL
    Next time, from a cmd prompt, try running "net start rpcss"

    Does that resolve it? If not, what does it say? Does it say already started? Error?