close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

HELP!! Connector problem

Discussion in 'General Glocking' started by KappaAlphaASU, Oct 30, 2012.

  1. KappaAlphaASU

    KappaAlphaASU

    402
    19
    Mar 20, 2009
    Arkansas
    I just got done installing a Ghost Ultimate 3.5# connector in my G19. Well the trigger pull & break are great but when I recock the gun & try to reset the trigger, it fires again. Now before someone says something about the other recent thread about the trigger bar & firing pin connection being bad, this gun ONLY does it with THAT connector. I put the stock connector in & it works fine. I also put a Lone Wolf connector in & it works fine too. Has anyone else ever had a problem like this before with a Ghost connector or any other connector??
     
  2. JesseA

    JesseA Glock Historian

    55
    0
    Oct 7, 2012
    Shawnee Oklahoma
    Did u replace the springs also? The ultimate trigger is the one u have to file down right?
     


  3. Roering

    Roering Sorting nuts

    5,233
    147
    Feb 14, 2008
    Costa Mesa
    Is the connector flush up against the plastic housing or does it stick out to the side a little bit?

    It's supposed to stick out a little.
     
  4. 1RoundEye

    1RoundEye

    559
    8
    Feb 21, 2010
    I've heard of other's who have installed a ghost connected and it resulted in consistent double taps. I believe he ended up just filing too much off which caused the striker lug to slip.
     
  5. KappaAlphaASU

    KappaAlphaASU

    402
    19
    Mar 20, 2009
    Arkansas
    I didn't replace any springs & the connector does stick out from the housing a little. I've replaced numerous connectors in numerous Glocks & have never had this problem before. I don't know if it's the connector or the gun or the combination. I put the same connector in my 27 & my 22 & it worked fine in both of them.
     
  6. Arc Angel

    Arc Angel Deus Vult!

    6,920
    6
    Sep 20, 2003
    Penn's Woods
    Here,

    http://www.ghostinc.zoovy.com/category/istallationinstructions/

    Read Section II, Notes 1. & 2. You don't need to get yourself anymore confused by coming to Glock Talk for a possible solution. Ghost has already done this for you. Your problem can be solved by carefully reading and following the advice stated in Note 2.
     
  7. JBUS

    JBUS I'mHellaJelly!

    245
    3
    Jun 28, 2011
    NorCal
    Per Ghost, the Ultimate is straight drop in.

    I had a lot of questions about the Ghost as I am going to the NY1 & 3.5#.

    Some Google searching and I ended up ordering the Ultimate since it's a drop in.
     
  8. glockenturm

    glockenturm

    271
    0
    Jan 26, 2010
    ATX
    This is why I never mess with a gun intended for SD purposes. What is a justifiable shooting of a perpetrator just released by your local lib DA now becomes a negligent discharge manslaughter case because the trigger group has been messed with, saving face for the DA, who is running for re-election.

    posted using Outdoor Hub Campfire
     
  9. Arc Angel

    Arc Angel Deus Vult!

    6,920
    6
    Sep 20, 2003
    Penn's Woods
    1. On an EDC replacing the springs is NOT something that you want to do.

    2. No. The, 'Ghost Ultimate Connector' is the same design as Glock factory. It simply drops in. Personally, I prefer the adjustable trigger stop on the, 'Ghost Rocket'.
     
  10. jim7777b

    jim7777b E9 USN Ret Millennium Member

    103
    0
    Feb 2, 1999
    Wichita
    Ghost Connector was installed on all 4 of my guns (just to be sure) and it double tapped with every one. Drop dead gorgeous drop in!
    :dunno:
     
  11. lethal tupperwa

    lethal tupperwa

    8,665
    587
    Aug 20, 2002
    Virginia
    why not replace the STOCK connector?

    It worked right?