close

Privacy guaranteed - Your email is not shared with anyone.

Help Before I Kill My Computer!

Discussion in 'Tech Talk' started by Powder, Apr 6, 2009.


  1. Powder

    Powder
    Expand Collapse

    Joined:
    Aug 26, 2003
    918
    35
    Location:
    Tampa, FL
    Not sure why but all of a sudden I can't use my digital camera or portable harddrive with the computers USB port. Before I would plug it in and get a popup with options to open the device. It would also show up in "My Computer". Now, nothing.

    It does show the small icon on the bottom right of the screen which lets you safely remove the device. I just can't open it.

    Any ideas.
     

    Wanna kill these ads? We can help!
  2. gh0st614

    gh0st614
    Expand Collapse

    Joined:
    May 4, 2003
    2,354
    0
    Location:
    Columbus, OH
    Sometimes my external will act up, I just unplug it and plug it in again. Maybe try a restart as well.
     

  3. Powder

    Powder
    Expand Collapse

    Joined:
    Aug 26, 2003
    918
    35
    Location:
    Tampa, FL
    Tried that 10 times already.

    My computer "sees" it in the "safely remove hardware" tab but nowhere else.
     
  4. Sgt. Schultz

    Sgt. Schultz
    Expand Collapse
    Annoying Member

    Joined:
    May 21, 2004
    2,195
    8
    Location:
    West Columbia, South Carolina
    First be sure that USB support is enabled in the BIOS even if you know you didn't change any settings.

    Check the Device manager and confirm that there are no flags listed under USB including one that says "Enhanced".

    Next you can try deleting them in device manager and then rebooting to see if that clears it up
     
  5. Detectorist

    Detectorist
    Expand Collapse

    Joined:
    Jul 16, 2008
    13,816
    3,142
    Location:
    Missouri
    Powder, I'm sure you're tried your other USB ports?

    Go to Device Manager. Scroll to the bottom where it says 'Universal Serial Bus Controllers'. You will see a bunch of entries that say 'Root Hub'. Starting from the top one, right click on each and then delete. When you're almost done, you might have to navigate with your keyboard since your mouse will not work.

    Reboot. The system will automatically reinstall those drivers.

    If that doesn't work, let us know which operating sytem you have so I can further assist you.

    90% of the time when deleting and reinstalling the root hub doesn't work, your mobo is fried.
     
  6. MavsX

    MavsX
    Expand Collapse
    The Dude Abides

    Joined:
    Jan 19, 2009
    3,033
    0
    Location:
    Arlington, VA
    try a different USB port, like above poster. Sometimes devices just get screwy and the best thing is to try a different USB port..or delete them in device manager!
     
    #6 MavsX, Apr 9, 2009
    Last edited: Apr 9, 2009
  7. Viper16

    Viper16
    Expand Collapse

    Joined:
    Apr 2, 2007
    1,399
    17
    Location:
    Oklahoma
    sometimes windows like to put the same volume for two items. if you have a few hard drives and network paths along with cd/dvd roms it may be conflicting.

    how many volumes do you have (ie. A:, B:, C:, D:, E:, F:, etc.) ? You may have to change one that is past D: to a letter further down on the alphabet to get let the USB drive register.
     
  8. Tennessee Slim

    Tennessee Slim
    Expand Collapse
    Señor Member
    CLM

    Joined:
    Apr 14, 2004
    4,413
    0
    Location:
    Mucus City, USA
    +1

    If a cold shutdown doesn't set it right, I'd recommend deleting it from device manager and rebooting.
     
  9. MavsX

    MavsX
    Expand Collapse
    The Dude Abides

    Joined:
    Jan 19, 2009
    3,033
    0
    Location:
    Arlington, VA
    i win!