close

Privacy guaranteed - Your email is not shared with anyone.

Gen2 Conundrum

Discussion in 'General Glocking' started by Tiro Fijo, Jun 30, 2011.

  1. Tiro Fijo

    Tiro Fijo

    Joined:
    May 31, 2011
    Messages:
    6,281
    Likes Received:
    9
    I bought a used Gen2 G19 recently and am having light hits before & after the six part upgrade. I have replaced the following:

    New OEM Recoil spring
    New extractor GLSP00098
    New trigger bar GLSP02303
    New OEM Slide lock spring
    Vickers Tactical slide stop
    New FP safety & spring
    Extractor Dep. Plunger GLSP00112
    Extractor Dep. Plunger Spring & bearing
    New FP GLSP00049
    New FP spring
    New cups
    New FP spacer
    New channel liner

    The old channel liner was loose and I still can't get the new one to seat permanently to I have lightly emeried it & will use a 3/8" dowel tomorrow.

    I had light hits as well BEFORE gutting the internals and worte it off to Win. WB ammo. However, it did the same AFTER the parts upgrade and even on some Fed. BPLE. That has me worried. I have checked everything, even the slide lock. Everything looks great & appears to be in spec.

    Any ideas? :dunno:
     
  2. JR

    JR Moderator Millennium Member

    Joined:
    Dec 29, 1998
    Messages:
    3,054
    Likes Received:
    1
    Location:
    Oldtown Idaho USA
    I would suspect the breach face has a thickness issue. Contact GI warranty and make arrangements to return the slide to the factory
     

  3. Tiro Fijo

    Tiro Fijo

    Joined:
    May 31, 2011
    Messages:
    6,281
    Likes Received:
    9