close

Privacy guaranteed - Your email is not shared with anyone.

FTEs with 17L

Discussion in 'General Glocking' started by Total_Recoil, Feb 11, 2012.

  1. Total_Recoil

    Total_Recoil

    Joined:
    Oct 27, 2005
    Messages:
    123
    Likes Received:
    0
    I shot my 17L and probably 15 out of 100 rds had trouble ejecting. They weren't stovepipes but the spent case would just jam the slide open lengthwise. Looks like the slide is going all the way back because the next round is partially fed, and looks like it would go into battery if it weren't for the spent case jamming things up.

    My theory is that standard pressure loads are not pushing the heavy 17L slide fast enough, to eject forcefully. I read elsewhere where a 17L owner said NATO and +P worked fine, but not std pressure.

    What do you guys think the problem is?
     
  2. voyager4520

    voyager4520 -----

    Joined:
    Apr 25, 2009
    Messages:
    8,589
    Likes Received:
    1
    Location:
    SE Colorado
    What ammo are you shooting when this happens? How many rounds have been through the gun total? What's the test-fire date on the envelope with spent casings that came with the gun?

    15 out of 100 failures to eject is pretty extreme, it sounds like either you're shooting really weak ammo or the extractor may not be moving freely enough. Standard pressure 9mm should work fine in a G17L.
     

  3. MarcDW

    MarcDW MDW Guns Millennium Member

    Joined:
    Oct 20, 1999
    Messages:
    3,718
    Likes Received:
    2
    Location:
    Maine USA
    If it's quality factory ammo it should not have this problem.
    What ammo do you use and did you clean the gun?
     
  4. DannyR

    DannyR Moderator Millennium Member

    Joined:
    Dec 17, 1998
    Messages:
    19,915
    Likes Received:
    243
    Location:
    Roanoke, Virginia
    If you are using Federal Champion Ammo, ditch it and get some real ammo. Try some Winchester USA or any S&B. Does your 17L have the stock recoil spring assembly?
     
  5. 9mmdude

    9mmdude

    Joined:
    Sep 8, 2001
    Messages:
    1,786
    Likes Received:
    21
    Location:
    USA
    Is it a new 17L or an older one?
     
  6. Total_Recoil

    Total_Recoil

    Joined:
    Oct 27, 2005
    Messages:
    123
    Likes Received:
    0
    The 17L is about 4 years old. All stock. Shot WWB and Aguila HP
     
  7. misfit356tsw

    misfit356tsw

    Joined:
    Jan 26, 2011
    Messages:
    976
    Likes Received:
    0
    Location:
    Land of the liberals
    New guide rod and spring?
     
  8. C0untZer0

    C0untZer0

    Joined:
    May 16, 2011
    Messages:
    489
    Likes Received:
    0
    I haven't ever experienced this problem. I've mostly settled on Blazzer Aluminum and Brass, but I have shot boxes of WWB, Remington L9MM3 and Wolf without any problems like what you describe.
     
  9. bolling

    bolling

    Joined:
    Aug 20, 2011
    Messages:
    108
    Likes Received:
    0
    It does not have a heavy slide, that is what the cut out is for to lighten it so a standard spring can be used. You should not have any trouble with the ammo you are using. Mine cycles fine with all kinds of cheap ammo. Did you buy it new and if not maybe someone put a none stock spring in it.