Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Forum at

Why should YOU join our forums?

  • Connect with other Glock Enthusiasts
  • Read up on the latest product reviews
  • Make new friends to go shooting with!
  • Becoming a member is FREE and EASY

Glock Talk is the #1 site to discuss the world’s most popular pistol, chat about firearms, accessories and more.

Failure to feed with the last round or second to the last round?

Discussion in 'General Glocking' started by g34gen4, Nov 18, 2012.

  1. g34gen4


    Sep 13, 2011
    I’m having issues with failure to feed the last round or second to the last round in my G30 Gen4 mags. It will start up the ramp but the slide won't continue into battery the last 1/4" even if I pull the slide back a little bit, let go. I was thinking it was the ammo but I’m still having the problem after trying 3 types of ammo (Federal, Winchester and Lawman). I called Glock and they sent me a new RSA but still didn’t fix the problem.

    Now I’m thinking it’s a mag issues because I tried my G21 13 round mag and it functioned faultless. Anyone know of any issues with the .45 10 round mags? Is there any way to test them? Just wondering if anyone has encountered an issue similar to mine and did it get corrected. Thanks
    Last edited: Nov 18, 2012
  2. CDW4ME


    Jun 5, 2009
    I had a similar issue with my 30SF and 10 round magazines:

    As a follow up to that thread,
    I ended up getting a couple more 9 round flush fitting magazines and they feed fine.
    I still prefer my 185 gr. bullet over 230 gr. Ranger T due to recoil.