close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

Crimson Trace on my 19

Discussion in 'Sights, Optics and Lasers' started by Treefrog23, Dec 14, 2012.

  1. Treefrog23

    Treefrog23

    6
    0
    Aug 14, 2010
    I have a CT laser on my SR22, and a LG412 on my LC9. I couldn't be more pleased with the Laser guard on the LC9, so I bought one for my Gen 3 Glock 19.

    When you bring the pistol up on the LC9 the sight activates perfectly. The one on my 19 requires a great deal of pressure to activate, to the point my hand shakes. I sent it back, it was retuned (no record of what they did), but it is still very hard to activate. Is anyone else having this problem?
    TF
    Knoxville, TN
     
  2. Rich22

    Rich22

    357
    2
    Dec 10, 2001
    Orlando, Fl
    I have two of them, LG436 to be exact, it does not require any more pressure than normal for me. 1 turns on practically if you look at it hard or in a stiff breeze.
     


  3. fishflash

    fishflash

    5
    0
    Dec 31, 2012
    I have them on my Gen 4 19 and have no problems. You may have gotten a bad switch. I have them on other handguns as well and function easily. Have you contacted the mfg and explained the situation. They're very easy to talk to and the CT is such a good value. Good luck