close

Privacy guaranteed - Your email is not shared with anyone.

AccuTrigger problems...

Discussion in 'Rimfire Forum' started by hotrodcummins12v, Sep 2, 2012.


  1. hotrodcummins12v

    hotrodcummins12v
    Expand Collapse

    Joined:
    Apr 3, 2012
    73
    0
    Location:
    Fredericksburg, PA
    So I just bought a Savage Mark II BV in .22 LR, and the thing shoots great. My only complaint is the trigger doesn't seem to reset right all of the time, and I have to rotate the bolt handle a couple times to get the trigger to function. Anyone else have this issue? Easy fix or should I spend the time and shipping to send it back to Savage?



    Sub Club 828
    1911 Club 828
    Outdoor Hub Mobile
     

    Attached Files:

  2. Chicken-Farmer

    Chicken-Farmer
    Expand Collapse

    Joined:
    Aug 30, 2009
    6
    0
    Have you tried to adjust the trigger? Maybe the trigger is set too light and the sear cannot engage properly
     

  3. hotrodcummins12v

    hotrodcummins12v
    Expand Collapse

    Joined:
    Apr 3, 2012
    73
    0
    Location:
    Fredericksburg, PA
    No, I haven't yet. When I get some time, I'll look at it closer.

    Sub Club 828
    1911 Club 828
    Outdoor Hub Mobile
     
  4. Chicken-Farmer

    Chicken-Farmer
    Expand Collapse

    Joined:
    Aug 30, 2009
    6
    0
    I would try that first. By resetting the bolt repeatedly you may finally get the sear to seat. It sounds to me like your trigger is set too light, right at the limits. Should be as simple as turning the sear adjustment screw with the included yellow handled tool.