close

Privacy guaranteed - Your email is not shared with anyone.

Welcome to Glock Talk

Why should YOU join our Glock forum?

  • Converse with other Glock Enthusiasts
  • Learn about the latest hunting products
  • Becoming a member is FREE and EASY

If you consider yourself a beginner or an avid shooter, the Glock Talk community is your place to discuss self defense, concealed carry, reloading, target shooting, and all things Glock.

650 priming

Discussion in 'Reloading' started by shotgunred, Sep 1, 2012.

  1. shotgunred

    shotgunred local trouble maker

    8,728
    951
    Mar 1, 2008
    Washington (the state)
    I sit down to load today and the press is binding. After looking thing over I figure out that the priming system is not working. I take it all apart and can't see anything out of place. I put it back together and it seems to be working fine. I put it back in the press and it works by hand. Load up some primers and it binds back up. I then did the same thing again. By the time the third primer is in the system its binding up again.

    Has anyone else had similar a problem or know a solution?
     
  2. unclebob

    unclebob

    7,362
    342
    Oct 14, 2000
    Mary Esther FL
    Did you take the primer assembly all apart? Do you have the right primer magazine installed? Without any primers in the magazine operating the handle does the primer mechanism work or is it still binding? Do you have the handle a little forward,(handle towards you) when trying to advance the primers?
     


  3. unclebob

    unclebob

    7,362
    342
    Oct 14, 2000
    Mary Esther FL
    Also make sure the primer punch is flush and not sticking up a little.
     
  4. shotgunred

    shotgunred local trouble maker

    8,728
    951
    Mar 1, 2008
    Washington (the state)
    I took it completely apart.
    I put it back together and it works fine until I put primers in it. then after a couple of primers the disk binds and and will not rotate, this of course binds up the whole press.
    I double checked that it was the small disk. I don't use the large one.
     
  5. Boxerglocker

    Boxerglocker Jacks #1 Fan

    6,146
    26
    Mar 6, 2003
    Lynnwood, WA
    Mike, Have you lubed the primer wheel lately? Make sure the knurled funnel nut that hold the primer magazine tube down in the blast tube is just barely snug. Also check if the brass end of the tube, may have burrs.
     
    Last edited: Sep 1, 2012
  6. unclebob

    unclebob

    7,362
    342
    Oct 14, 2000
    Mary Esther FL
    You do have the small primer magazine tube installed? It’s jamming up when you try and manually try to advance the primers or using the press to advance the primers. Everything works fine when you have no primers installed. Both using the press and manually advancing the primer disk? If it works fine both ways? I would say you don’t have the primer magazine installed or you have the wrong primer magazine installed. Or the brass it is not down in the hole all the way. Either the primer punch is sticking up a little or you have something installed wrong.
     
  7. unclebob

    unclebob

    7,362
    342
    Oct 14, 2000
    Mary Esther FL
    Nice picture of a small boat anchor.:supergrin:
     
  8. Colorado4Wheel

    Colorado4Wheel

    14,933
    166
    Nov 2, 2006
    CO
    So if you try and push it by hand on the lever it won't move?

    Did you put on a new tip?
    Polish the wheel to remove any burrs? The lever can cause a burr on the wheel.

    Otherwise call Dillon as I have no clue. I will be curious as to what you find.
     
  9. F106 Fan

    F106 Fan

    8,033
    268
    Oct 19, 2011
    Does this happen with one brand of primer and perhaps not with another?

    I bought a case of Tula .223 primers and I'm not impressed with the way the anvil doesn't stay inside the cup. They haven't jammed my 650 (yet!) but I could see where they might be a problem.

    Richard
     
  10. shotgunred

    shotgunred local trouble maker

    8,728
    951
    Mar 1, 2008
    Washington (the state)
    As long as there are no primers in the primers the disk it works fine. After I put primers in the tube and start to operate the priming system after a few primers it jams up tight and i cannot operate it by hand or by the machine.
    When I run my finger over the disk I can tell which side it was pressed from so today I will clean it up and polish it. I have been getting a few mangled primers now and then so I am begging to think that I need a new primer disk.

    If I don't figure it out by Tuesday then I will call Dillon.
     
  11. unclebob

    unclebob

    7,362
    342
    Oct 14, 2000
    Mary Esther FL
    Are you using the right size primer magazine? It’s the tube that goes inside primer assembly. It’s the tube with the brass tip on the end. If you don’t have it installed or are using the wrong one it will jam things up.
     
  12. fredj338

    fredj338

    21,662
    898
    Dec 22, 2004
    so.cal.
    Not even that, too light for a good boat anchor.:tongueout:
     
  13. shotgunred

    shotgunred local trouble maker

    8,728
    951
    Mar 1, 2008
    Washington (the state)
    Sorry nothing yet. My dad has spent the last 12 days in the ICU so I totally forgot to deal with it.
     
  14. unclebob

    unclebob

    7,362
    342
    Oct 14, 2000
    Mary Esther FL
    Our thoughts and prayers are with you also.