Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 02-18-2013, 21:58   #1
njFFRescue
Member
 
njFFRescue's Avatar
 
Join Date: Apr 2012
Location: New Jersey
Posts: 40
One rail turned copper color

Hey ya ll,


So while I was cleaning my G19 Gen 4 I noticed that I had a bit of a copper color developing on one of the rails. Nothing major, gun operates fine. Had about 2k round through it.

Is this a problem? Thanks so much everyone.

Sent from my HTC One X using Tapatalk 2
njFFRescue is offline   Reply With Quote
Old 02-18-2013, 22:18   #2
tonyparson
Senior Member
 
tonyparson's Avatar
 
Join Date: Jan 2008
Location: Dayton, TN.
Posts: 5,267
Are you talking about the copper grease Glock puts on all there Glocks when they leave the factory? Can you post a picture?
__________________
When the people fear their government, there is tyranny; when the government fears the people, there is liberty.......
Thomas Jefferson
tonyparson is offline   Reply With Quote
Old 02-18-2013, 22:35   #3
kodiakpb
Senior Member
 
kodiakpb's Avatar
 
Join Date: Jan 2012
Posts: 2,083
I think he's talking about a wear mark on the frame rail.
kodiakpb is offline   Reply With Quote
Old 02-18-2013, 23:04   #4
skyboss_4evr
Senior Member
 
skyboss_4evr's Avatar
 
Join Date: May 2004
Location: Iowa
Posts: 3,225


Nothing to worry about. All my Glocks show similar wear on the rails.
__________________
"Courage is not the absence of fear... it is the conquest of it."
skyboss_4evr is offline   Reply With Quote
Old 02-18-2013, 23:24   #5
bentbiker
NRA Member
 
bentbiker's Avatar
 
Join Date: Sep 2009
Location: Orange County, CA
Posts: 4,552
When the steel frame rails are nickel plated, the first layer is copper to improve adhesion by the nickel. As wear takes place, the nickel wears a bit and the copper is visible.
bentbiker is offline   Reply With Quote
Old 02-19-2013, 05:25   #6
ku4hx
Senior Member
 
ku4hx's Avatar
 
Join Date: Mar 2007
Location: Georgia, USA
Posts: 233
Send a message via AIM to ku4hx
The plating has peeled off exposing the copper alloy substrate; happened to me too. I just polished mine with 600 grit emery cloth about 2,500 rounds ago and it hasn't changed since.
__________________
Demons run when a good man goes to war.

Last edited by ku4hx; 02-19-2013 at 05:26..
ku4hx is offline   Reply With Quote
Old 02-19-2013, 06:19   #7
njFFRescue
Member
 
njFFRescue's Avatar
 
Join Date: Apr 2012
Location: New Jersey
Posts: 40
Yep, you guys are right. Talking about the outermost layer wearing off revealing a brass/copper ish color underneath. M
The factory gunk has long been gone.

Is this normal after about 2k rounds or so?

Should I do anything about it?

Sent from my HTC One X using Tapatalk 2
njFFRescue is offline   Reply With Quote
Old 02-19-2013, 07:02   #8
voyager4520
-----
 
voyager4520's Avatar
 
Join Date: Apr 2009
Location: SE Colorado
Posts: 8,581
It's normal, sometimes the nickel plating disappears in as little as a few hundred rounds.
__________________
G23 G27

Last edited by voyager4520; 02-19-2013 at 07:02..
voyager4520 is offline   Reply With Quote
Old 02-19-2013, 08:00   #9
ray glock
Senior Member
 
ray glock's Avatar
 
Join Date: Apr 2007
Location: Texas
Posts: 1,686
I learn something every day. Good post. Most run their glock rails dry. I can't resist the temptation to slick mine up.
__________________
"Thy word is a lamp unto my feet, and a light unto my path." PSALM 119;105
ray glock is offline   Reply With Quote
Old 02-19-2013, 08:01   #10
njFFRescue
Member
 
njFFRescue's Avatar
 
Join Date: Apr 2012
Location: New Jersey
Posts: 40
I've been running mine with a drop of MPro7 gun oil.

Is there something better I should be using?

Sent from my HTC One X using Tapatalk 2
njFFRescue is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 15:56.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,178
357 Members
821 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31