GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 02-12-2013, 17:43   #1
polarctica
Registered User
 
Join Date: Feb 2009
Posts: 13
G20 - Fails to Pick up Next Cartridge

I have a fairly new G20sf that I'm quite fond of, however it almost always jams at least once going through a clip of 15 rounds. The jam consists of failing to pick up the next round from the clip. The fired round is ejected and the next round begins to lift from the clip and the slide actually smashes it in the middle of the case - doesn't pick it up at the rim, but appears to miss and catches the shell halfway. This leaves a nasty dent in the round.

This occurs with both the stock recoil spring and Wolff 20# spring.

I'm a very experienced shooter and believe I've got a firm hold (i.e. not limp-wristing it).

Any thoughts?
polarctica is offline   Reply With Quote
Old 02-12-2013, 17:53   #2
dsa1115
Senior Member
 
Join Date: Sep 2010
Location: Suburban Chicago
Posts: 597
Are you using factory ammunition or reloads? Are you using Glock brand mags, and have you experienced problems with a variety of magazines?
__________________
G26, G17, G34, G21 gen4, G42
dsa1115 is offline   Reply With Quote
Old 02-12-2013, 18:07   #3
F106 Fan
Senior Member
 
F106 Fan's Avatar
 
Join Date: Oct 2011
Posts: 6,060
It's very likely that the slide isn't coming all the way to the rear. Catching the case midway is exactly what would happen.

So, why isn't the slide coming all the way to the rear? Why not try the factory spring first? Or at least try it first...

What ammo are you using? If it is too wimpy, there won't be enough force to cycle the slide.

Richard
__________________
"No matter how cynical you become, it's never enough to keep up." - Lily Tomlin

Last edited by F106 Fan; 02-12-2013 at 18:08..
F106 Fan is online now   Reply With Quote
Old 02-12-2013, 18:36   #4
polarctica
Registered User
 
Join Date: Feb 2009
Posts: 13
Factory mags - I have 3 mags with the same results. I get the same results with the factory recoil spring, but it happens less frequently.

I have suspected my reloads, and I've tried different powder weights up and down to see if it changes anything - and it didn't - still jams. These are fairly stiff loads as well. I know this isn't a reload forum, but I'm using brand new DoubleTap nickel brass, with CCI300 primers, 10 gr of 800X and 180 gr Barry's or 180 gr Hornady XTP. I've gone lower and higher with the powder weight as well. Also used CCI 350's. I match factory OAL.

Are we leaning toward my reloads?
polarctica is offline   Reply With Quote
Old 02-12-2013, 18:37   #5
dbow
Member
 
Join Date: Jun 2012
Posts: 69
Quote:
Originally Posted by polarctica View Post
I have a fairly new G20sf that I'm quite fond of, however it almost always jams at least once going through a clip of 15 rounds. The jam consists of failing to pick up the next round from the clip. The fired round is ejected and the next round begins to lift from the clip and the slide actually smashes it in the middle of the case - doesn't pick it up at the rim, but appears to miss and catches the shell halfway. This leaves a nasty dent in the round.

This occurs with both the stock recoil spring and Wolff 20# spring.

I'm a very experienced shooter and believe I've got a firm hold (i.e. not limp-wristing it).

Any thoughts?
I'm no expert but i would try shooting from a rest. I would also try some different ammo. Either you are limpwristing, or your ammo is very weak.
__________________
Savage Model 11 - Nikon ProStaff 3X9X40 - 85 grain HSA Sierra HPBT
Glock 20 Stock 10mm - Underwood Delta Elite 180 grain JHP
Mathews Helim - 64lbs - Axion Gridlock 5pin - G5 Archery Expert II
dbow is offline   Reply With Quote
Old 02-12-2013, 18:38   #6
CybrSlydr
Senior Member
 
Join Date: Jan 2013
Posts: 107
Quote:
Originally Posted by polarctica View Post
I'm a very experienced shooter...
Then one might think you would understand and know the difference between a clip and a magazine.

General Glocking

Pet peeve of mine...
CybrSlydr is offline   Reply With Quote
Old 02-12-2013, 19:01   #7
polarctica
Registered User
 
Join Date: Feb 2009
Posts: 13
Pet peeves, aside, I appreciate your feedback. I'll do some more shooting and try a rest. I'm a revolver man, and limp wristing doesn't have the same effect, so maybe some humble pie is in order.
polarctica is offline   Reply With Quote
Old 02-12-2013, 19:06   #8
GLOCK19FTW
Senior Member
 
GLOCK19FTW's Avatar
 
Join Date: Dec 2012
Location: SC
Posts: 808
I can't think of a single reason why a "fairly new" Glock wouldn't feed the next round.

If everything checks out, I'd send it in & have them fix or replace it.
__________________
….(\_/)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

...( ‘_’)
…/”"”"”"”"”"”\======░ · · · · · ·
/”"”"”"”"”"”"”"\
\_@_@_@_@_/
GLOCK19FTW is offline   Reply With Quote
Old 02-12-2013, 19:23   #9
rl356
Senior Member
 
rl356's Avatar
 
Join Date: Aug 2008
Posts: 199
May very well have something to do with the use of clips. If you happen to have some magazines for it (preferably factory made), load those up with some factory fresh ammunition, use the stock recoil spring, get a firm grip on it, and squeeze the trigger.
rl356 is offline   Reply With Quote
Old 02-12-2013, 19:26   #10
orangeride
Senior Member
 
Join Date: Oct 2011
Posts: 450
Have a glock guy run a few rounds through it. The good thing is it seems to be doing it almost every mag for you. It should be easy to figure out. I had new 20sf that was ftfeed jamming to the hard left but only did it every 30-50 rnds. I burned a lot of ammo figuring that one out. Either the slide is not coming back far enough or there's something wrong with the mag catch and how the mag is held in position. How far does it throw the empty's? You need 2-3' to ensure reliable function. You can load lighter but you really need to keep things tight. Good luck.
orangeride is offline   Reply With Quote
Old 02-12-2013, 19:33   #11
dbow
Member
 
Join Date: Jun 2012
Posts: 69
i also did experience the same failures with my G20 when i first got it. I purchased a dpi spring and it didn't really help until i shot about 50 rounds with a rest. Problem went away. Anyway, in my case, it was the indian, not the bow.
__________________
Savage Model 11 - Nikon ProStaff 3X9X40 - 85 grain HSA Sierra HPBT
Glock 20 Stock 10mm - Underwood Delta Elite 180 grain JHP
Mathews Helim - 64lbs - Axion Gridlock 5pin - G5 Archery Expert II
dbow is offline   Reply With Quote
Old 02-12-2013, 19:42   #12
polarctica
Registered User
 
Join Date: Feb 2009
Posts: 13
Thanks for the feedback. Feedback is pretty consistent. For guys who don't live and breathe this stuff, you are all very helpful and keep the newcomers....coming.
polarctica is offline   Reply With Quote
Old 02-12-2013, 20:19   #13
BMiracletx
Senior Member
 
BMiracletx's Avatar
 
Join Date: Aug 2012
Location: Abilene, TX
Posts: 606
Add another one to the list on this. I had a 20sf that I couldn't get to run right. Glock was no help and I tried 6 different mags, regular mag springs and extra power mag springs, 4 different weights of recoil springs, and every way of holding it and could never get it sorted out... until I switched reloading dies.

By chance are you loading your 10mm with Hornady dies? I found that my Hornady sizing die was out of spec and wasn't sizing the case down enough causing some setback when the round hit the feed ramp and causing it to "stick". I switched to a Redding sizer die and it all went away.

Last edited by BMiracletx; 02-12-2013 at 20:20..
BMiracletx is offline   Reply With Quote
Old 02-12-2013, 22:51   #14
cityborncountrylivin
Senior Member
 
Join Date: Feb 2013
Posts: 155
I had problems with hornaday 10mm also
cityborncountrylivin is offline   Reply With Quote
Old 02-12-2013, 22:57   #15
ron59
Bustin Caps
 
ron59's Avatar
 
Join Date: Jan 2009
Location: near Atlanta, GA
Posts: 6,813
What type of bullet you using?

I've heard of Glocks in .45ACP having problems with wad cutters (I realize you have a 10mm but it could be related). I think the feed ramp angle is the issue. Try some factory ammo or something (ball ammo) if you haven't done so.

Maybe your OAL needs to be changed in that gun if it's not wadcutters.
__________________
Ron M. ('59 is my birth year)

Quote:
“WTF?! How a cheap can an old, the old fart get?!”

Last edited by ron59; 02-13-2013 at 09:10..
ron59 is offline   Reply With Quote
Old 02-13-2013, 08:23   #16
SDGlock23
Glockoholic
 
SDGlock23's Avatar
 
Join Date: Jan 2005
Location: Land of Forgetfulness
Posts: 7,691
Quote:
Originally Posted by polarctica View Post
. I know this isn't a reload forum, but I'm using brand new DoubleTap nickel brass, with CCI300 primers, 10 gr of 800X and 180 gr Barry's or 180 gr Hornady XTP.
Yeah that's pretty stiff. Book max for a 180gr jacketed is 8.7gr, so you're 15% over book, I'm not really sure what max is for plated, which needs to be loaded like lead. How does your brass look? While it's possible that it's your gun, it could be your handloads too.
__________________
"Condemnation without investigation is the height of ignorance."
SDGlock23 is offline   Reply With Quote
Old 02-13-2013, 11:57   #17
polarctica
Registered User
 
Join Date: Feb 2009
Posts: 13
I will go back and try factory loads again and work on some more reloads and check my aol....and focus on what may be my limp wrists (rats). I use Lee dies and I haven't treated Barry's any different than the XTPs.

I started my loads at 8 gr of 800x and worked up thinking my recoil spring was too strong, but then again, it happens with the factory recoil spring. My fired brass and primers are very much the same between 9 gr and 10 gr, and I'm comfortable with the load.

However - I hadn't thought of this before, my brass for reloads or factory loads have a dent or dimple 3/4 of the way up the brass that is about the size of the tip of a Sharpy (marker). It isn't deep, but obvious. Is this normal? I don't see how whatever is causing this could be causing feeding problems, but again...

By the way, I said my G20sf is "fairly new." I purchased this brand new 5 or 6 years ago and have put around 400 rounds through it - off and on between my frustrations. In my mind that constituted 'fairly new.'

Thanks again, everybody.
polarctica is offline   Reply With Quote
Old 02-13-2013, 16:30   #18
ii's open
Registered User
 
Join Date: Dec 2012
Posts: 1
Buy a 1911 problem solved. Jokes aside, have you tried polishing the feed ramp? I had a similar problem with a aftermarket barrel(stormlake) wouldn't cycle, I suspected the angle of the feed ramp was off. I returned it and bought another barrel problem solved.
ii's open is offline   Reply With Quote
Old 02-15-2013, 07:36   #19
Matt Berry
Senior Member
 
Join Date: Dec 2007
Posts: 151
I'm surprised no one else has asked, but since you are using reloads, do you have a case gauge? Have you checked your ammo to see if it will pass a case gauge or barrel check. When I first started reloading I didn't check my rounds. Now days I use a case gauge for every one. Sure it adds a little more time to the process, but I don't have to worry about out of spec ammo causing the occasional failure to feed.
Matt Berry is offline   Reply With Quote
Old 02-15-2013, 08:22   #20
F106 Fan
Senior Member
 
F106 Fan's Avatar
 
Join Date: Oct 2011
Posts: 6,060
On the underside of the slide there is a ramp that is supposed to ride over the top of the round in the magazine. As the slide travels to the rear, this ramp should eventually get behind the top round and shove the case up the feed ramp.

This isn't happening, right?

So, either the slide isn't coming all the way to the rear or the top round isn't in the right position. Is there any chance that your OAL combined with the bullet profile is dragging in the magazine?

Take the barrel out of the gun and drop a few rounds in the chamber. They should ride on the edge of the case mouth (where it hits the ridge at the front of the chamber), the bullet should not contact the rifling and the round should spin easily.

Another possibility is the bevel on the leading edge of the ramp on the slide. Here is a discussion:
http://www.glockpost.com/forums/showthread.php?t=13970

You can see from the pictures that Glock has changed the bevel throughout the life of the guns. I'm not suggesting you add to the bevel but if you get a chance to see a similar gun, check if it matches yours.

Then there is bullet profile. What are you using and how does it compare with factory?

In fact, how does factory ammo work in your gun? I am willing to put all the blame on your reloads but it would be easier to justify if factory ammo worked perfectly.

I find it odd that Hodgdon doesn't provide a minimum charge for 800-X but I also wonder why you are so far over MAX. When the round fires, the case expands against the chamber. The prevents the case from moving rearward in the chamber until the pressure dies off. When the case finally moves to the rear, it unlocks the breech by pushing the slide to the rear away from the barrel.

I can't imagine that being overpressure helps the situation. It just about has to interfere with the timing of the unlocking and the impulse of the recoil. Whether this would slow the slide down or speed it up, I have no idea.

In the 1911 world, we use a rubber buffer on the recoil guide rod to absorb the impact of the slide against the frame. One result is that the slide doesn't move as far to the rear. You don't have anything like this in your Glock, right?

I'm just tossing out things to think about. Most probably won't be helpful.

Richard
__________________
"No matter how cynical you become, it's never enough to keep up." - Lily Tomlin
F106 Fan is online now   Reply With Quote

 
  
Reply


Tags
ftrtb, g20sf
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 10:10.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 938
289 Members
649 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31