GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 11-03-2012, 21:00   #1
Treefrog23
Registered User
 
Join Date: Aug 2010
Posts: 6
Crimson Tace

Is anyone having problems with CT's? I have one each on my Ruger 9mm, works fine. I just bought a CT Laserguard for my Gen 3 G-19, the problem is, it is very hard to activate the on button. I can change my grip and get it to work, but that's not good. It feels like the activation button is being hindered by the grip and does not want to activate. Any suggestions would be greatly appreciated.
TF
Eat Tennessee
Treefrog23 is offline   Reply With Quote
Old 11-04-2012, 11:04   #3
Magnum 357
Senior Member
 
Join Date: Apr 2007
Posts: 321
I agree with 4Rules. They have the best customer service in the industry. Contact them!!!
__________________
The richest person is NOT the one who has the MOST… but the one who needs the LEAST!!!
Don't be scared be prepared!
If guns were outlaw only outlaws will have guns - NRA
Si vis pacem para bellum
Magnum 357 is offline   Reply With Quote
Old 11-04-2012, 15:38   #4
Treefrog23
Registered User
 
Join Date: Aug 2010
Posts: 6
I greatly appreciate the suggestions. I did call them and got a rep, who told me to work with it a while to see if the problem resolves itsef, which I doubt it will. I'll try them again tomorrow.

Again my thanks for your help.
TF
Treefrog23 is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 07:38.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 785
227 Members
558 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31