Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 04-30-2013, 17:09   #1
Caine
Member
 
Join Date: Jul 2005
Posts: 60
Glock 27 Gen 4 recoil spring question

I just purchased a new Gen 4 G27. Gun was manufactured in April 2013. I have not yet taken it to the range. After disassembly and function checks, I noticed that the recoil spring is not as stiff as other Gen 4 models I have shot. I realize that the gun will likely shoot great, despite the quirks of this spring. Yet, when intentionally riding the slide forward with the muzzle pointed to the sky, my G22 will still fully and firmly go into battery, whether loading a round or without a mag installed. The spring in the 22 is noticeably stronger than the one in my G27. The G22 has about 100 rounds through it. The G27, when I ride the slide forward, will stop about 1/8 of an inch from going into battery, with or without a round in the mag.

I understand the stupidity of riding any slide and never do that when actually firing. I am simply doing this to see if I have a weak or defective spring assembly from the factory. I am going to try another spring, just wondering if anyone else has seen this on the G27. Thanks.
Caine is offline   Reply With Quote
Old 04-30-2013, 19:45   #2
Redstate
Senior Member
 
Redstate's Avatar
 
Join Date: May 2011
Posts: 801
You might be interested in this thread: http://www.glocktalk.com/forums/show....php?t=1419549
Redstate is offline   Reply With Quote
Old 04-30-2013, 19:56   #3
DannyR
Moderator
 
DannyR's Avatar
 
Join Date: Dec 1998
Location: Roanoke, Virginia
Posts: 38,378
Your RSA has been in use by Glock since December 1995, and is a proven design.
__________________
Lifetime GSSF Member
Certified Glock Armorer 1997-2015
NROI, Level I
Bull Dawg #1

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
DannyR is offline   Reply With Quote
Old 04-30-2013, 20:41   #4
smithmap
Registered User
 
Join Date: Jan 2013
Posts: 5
Same issue a month ago and Glock sent a new RSA. Problem solved.
smithmap is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 06:14.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 624
147 Members
477 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31