Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 09-30-2012, 15:25   #1
matt_lowry123
Senior Member
 
matt_lowry123's Avatar
 
Join Date: Nov 2008
Location: owensboro KY
Posts: 1,532
Ruger 1911 help

I'm not new to the 1911 platform, but I'm new to this problem. I took it out today to go shoot and when I got back home to clean it. I noticed that the left side of the frame rail is getting marred up. It looks like somebody did a 30 LPI on the side of the rail. It runs good and I haven't had a problem out of 500 rounds or so. You think I should call ruger? Anybody else have this kind of problem before?
matt_lowry123 is offline   Reply With Quote
Old 09-30-2012, 16:51   #2
dakrat
Senior Member
 
dakrat's Avatar
 
Join Date: May 2007
Location: worldwide, on time, on target
Posts: 2,872
do you have a picture? have you noticed any debris?
__________________
---Revolvers are the future---
dakrat is offline   Reply With Quote
Old 09-30-2012, 17:08   #3
CanMan
Senior Member
 
CanMan's Avatar
 
Join Date: Jun 2012
Location: in flagrante
Posts: 965
Need a pic please... debris or the most severe galling I've ever heard of ??
CanMan is offline   Reply With Quote
Old 09-30-2012, 17:10   #4
matt_lowry123
Senior Member
 
matt_lowry123's Avatar
 
Join Date: Nov 2008
Location: owensboro KY
Posts: 1,532
When I get back home I'll post a pic.
matt_lowry123 is offline   Reply With Quote
Old 09-30-2012, 17:28   #5
tsmo1066
Happy Smiley
 
tsmo1066's Avatar
 
Join Date: Aug 2004
Location: Houston, TX
Posts: 8,173


Sounds like galling, but if it as severe as what you describe I don't see how it couldn't be hindering proper function.

A pic is definitely needed!
__________________
Few men desire liberty; most men wish only for a fair master. - Sallust

May you have food and raiment, a soft pillow for your head, and may you be forty years in Heaven before the Devil knows you're dead! - Old Irish Toast
tsmo1066 is offline   Reply With Quote
Old 09-30-2012, 18:05   #6
HAMMERHEAD
Senior Member
 
HAMMERHEAD's Avatar
 
Join Date: Dec 2002
Location: Minnesota
Posts: 4,713
New stainless firearms need a proper break in, grease the rails often. You can switch to oil later.
Stainless on stainless is galling waiting to happen.

Last edited by HAMMERHEAD; 09-30-2012 at 18:06..
HAMMERHEAD is offline   Reply With Quote
Old 09-30-2012, 18:18   #7
matt_lowry123
Senior Member
 
matt_lowry123's Avatar
 
Join Date: Nov 2008
Location: owensboro KY
Posts: 1,532
Hang on and I'll send you a pic of the good side. I can't figure out this damn thing. I only have limited space to put the pics up.

Last edited by matt_lowry123; 09-30-2012 at 18:28..
matt_lowry123 is offline   Reply With Quote
Old 09-30-2012, 18:24   #8
matt_lowry123
Senior Member
 
matt_lowry123's Avatar
 
Join Date: Nov 2008
Location: owensboro KY
Posts: 1,532
This is the side that's tore up. I clean my guns after every range session. So if something got in there, it fell out before I got home to clean it.


Outdoor Hub mobile, the outdoor information engine

Last edited by matt_lowry123; 10-26-2012 at 18:36..
matt_lowry123 is offline   Reply With Quote
Old 09-30-2012, 18:32   #9
matt_lowry123
Senior Member
 
matt_lowry123's Avatar
 
Join Date: Nov 2008
Location: owensboro KY
Posts: 1,532
It keeps saying that I'm going over my limit on space. The other side is smooth. It looks like every other frame I have.
matt_lowry123 is offline   Reply With Quote
Old 09-30-2012, 18:36   #10
matt_lowry123
Senior Member
 
matt_lowry123's Avatar
 
Join Date: Nov 2008
Location: owensboro KY
Posts: 1,532
Quote:
Originally Posted by HAMMERHEAD View Post
New stainless firearms need a proper break in, grease the rails often. You can switch to oil later.
Stainless on stainless is galling waiting to happen.
I guess I should have used some grease!!!


Edit!!

I just googled "galling on sr1911" and it seems like I'm not the only one with this problem. That's a pisser that it had to happen to me. Oh well, it's still fun to shoot!!!

Last edited by matt_lowry123; 09-30-2012 at 18:44.. Reason: Updated
matt_lowry123 is offline   Reply With Quote
Old 10-01-2012, 03:55   #11
jstanfield103
Member
 
Join Date: Jul 2012
Posts: 56
The best thing you could do would be a Email to Ruger Customer Service. Send the pictures with the Email and see what they say. They will probably want the gun back to take care of the problem. They have a good turn around and it will be done right.
jstanfield103 is offline   Reply With Quote
Old 10-01-2012, 07:51   #12
Three-Five-Seven
Señor Mombo
 
Three-Five-Seven's Avatar
 
Join Date: Aug 1999
Location: Tucson
Posts: 3,297
Every 1911 I own has patches on the rails where the frame and slide have worn the surface of the metal. I don't see how this design could possibly be built without sacrificial wear of the rails and slide to one another.

I look at it as the "final fitting" of the gun. So, from that perspective, there's nothing to worry about.

The SR1911 I have is certainly the tightest, inexpensive 1911 I own. I always thought that was a virtue in the 1911 world. It's probably one of the reasons why the SR1911 has developed a reputation for being particularly accurate for the 1911 type.

I really don't see anything here to be concerned about. Do, however, keep the rails well lubricated. I like Posness-Warren grease for the rails.
__________________
That I could be wrong is an eventuality that has not escaped me. I just painted the pictures as I saw them. I do not know how to do anything else. (Saint Elmer, 1955)
Three-Five-Seven is offline   Reply With Quote
Old 10-01-2012, 09:04   #13
Gary1911A1
Senior Member
 
Gary1911A1's Avatar
 
Join Date: Jun 2005
Location: Ohio for now
Posts: 3,617
These pictures are why I want a SR1911 made in carbon steel.
Gary1911A1 is offline   Reply With Quote
Old 10-01-2012, 09:39   #14
Unk
Senior Member
 
Join Date: Jul 2010
Location: West Central FL
Posts: 193
1911 Forums

1911 Forums

OK so I'm no photojournalist..either.

I disassembled my two(2) SR1911 - one unfired and examined all rails. All I see are uniform, very faint tool marks on all rails.

As to galling as I recall was a very early issue in SS semi-auto pistols. The reason given was that the same exact SS could gall. The early fix was to use dissimilar SS and the problem was solved. Since that was many, many years ago would guess that new SS have developed and one non-galling SS is used.

I'd lube the rails and shoot it, if it worsens or just makes you mad send back to Ruger.

I'm not a SR1911 collector..the second one is for my son's Christmas present.

Best.
Unk is offline   Reply With Quote
Old 10-01-2012, 11:14   #15
ArmoryDoc
Senior Member
 
ArmoryDoc's Avatar
 
Join Date: May 2006
Location: Kansas
Posts: 5,900
There is nothing wrong with that gun. Run the rails with a lube (very light grease) and quit sweating the small stuff. It's going to wear, especially if you don't lube it. That gun is seriously fine.
ArmoryDoc is offline   Reply With Quote
Old 10-01-2012, 13:51   #16
grecco
Senior Member
 
grecco's Avatar
 
Join Date: Sep 2004
Location: philadelphia pa
Posts: 4,406


Quote:
Originally Posted by ArmoryDoc View Post
There is nothing wrong with that gun. Run the rails with a lube (very light grease) and quit sweating the small stuff. It's going to wear, especially if you don't lube it. That gun is seriously fine.
what he said,,,,
i usually apply slide glide and a drop of gun butter on the rails,
works for me.
__________________
There are those that DRINK the KOOL Aid,and then those that just get it.
Which one are you?
grecco is offline   Reply With Quote
Old 10-01-2012, 20:34   #17
azdave
Senior Member
 
Join Date: Mar 2007
Location: SE Arizona
Posts: 348
Quote:
Originally Posted by Unk View Post

As to galling as I recall was a very early issue in SS semi-auto pistols. The reason given was that the same exact SS could gall. The early fix was to use dissimilar SS and the problem was solved. Since that was many, many years ago would guess that new SS have developed and one non-galling SS is used.
THIS is correct.

Smith & Wesson found out the hard way in the 1980's with the advent of the second gen. 639's/659's that slides/frames of the identical SS material was an issue.
I still have a jar of Rigs STAINLESS +P Lube that was popular back then to avoid issues, before they figured it out.
azdave is offline   Reply With Quote
Old 10-22-2012, 18:56   #18
Arvinator
Senior Member
 
Join Date: Jan 2011
Posts: 199
I just bought a new Ruger SR1911. The rails look fine, and I have not shot it yet. I have already put Wilson's Ultima Lube grease to it...
Arvinator is offline   Reply With Quote
Old 10-23-2012, 10:05   #19
3rdgen40
.45 fanatic
 
3rdgen40's Avatar
 
Join Date: May 2008
Location: Arkansas
Posts: 8,208
Grease the slide and frame rails.Also put a thin layer of grease under the slide stop.The two rub spots I see look like the slide stop rubbing against high spots on the frame.
3rdgen40 is offline   Reply With Quote
Old 10-28-2012, 08:32   #20
Jim S.
Senior Member
 
Jim S.'s Avatar
 
Join Date: Dec 2008
Location: Northwest Indiana
Posts: 4,765
Whenever I buy a stainless 1911 I have gotten in the habit of polishing the frame rails with 1000g paper (wet).
I try to do the inside of the slide rails as well.
It really helps to make things slide better. You can tell the difference from normal to polished.
Then just a little bit of grease and it is good to go.
__________________
The Evil Captain Kirk
Jim S. is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 04:18.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 747
161 Members
586 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31